Nethserver update failure

v7
updates

(Paul Guerra) #1

NethServer Version: NethServer release 7.4.1708
Module: kmod-xt

I am getting a 416 error when trying to update using Yum. I have tried the following.

yum clean alll
rm -rf /var/cache/yum
rpm rebuilddb

I have included log of the update process with lines referring the module that fails. If anyone has any ideas I would greatly appreciate it.

    ---> Package kmod-libs.x86_64 0:20-15.el7_4.4 will be updated
    ---> Package kmod-libs.x86_64 0:20-15.el7_4.6 will be an update
    ---> Package kmod-xt_ndpi.x86_64 0:2.0.1-1.ns7 will be updated
    ---> Package kmod-xt_ndpi.x86_64 0:2.0.3-1.ns7 will be an update

     kmod-libs                                                               x86_64                                   20-15.el7_4.6                                                   updates                                               50 k
     kmod-xt_ndpi                                                            x86_64                                   2.0.3-1.ns7                                                     nethserver-updates                                   201 k


(10/133): kmod-libs-20-15.el7_4.4_20-15.el7_4.6.x86_64.drpm                                                                                                                                                           |  15 kB  00:00:00
(17/133): kmod-xt_ndpi-2.0.1-1.ns7_2.0.3-1.ns7.x86_64.drpm                                                                                                                                                            |  21 kB  00:00:00

Finishing delta rebuilds of 34 package(s) (181 M)
Some delta RPMs failed to download or rebuild. Retrying..                                               100% [=============================================================================================] 1.7 MB/s | 181 MB  00:00:00 ETA
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror.nethserver.org/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                         ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://nethserver.de-labrusse.fr/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror.framassa.org/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                           ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://smart-ict.services/mirror/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                     ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror.nordest.systems/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                        ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
https://markusneuberger.at/mirror/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTPS Error 416 - Requested Range Not Satisfiable                                   ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
https://mirror.alpix.eu/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTPS Error 416 - Requested Range Not Satisfiable                                             ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror1.nethserver.org/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                        ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror2.nethserver.org/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                        ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
https://mirror.nethesis.it/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTPS Error 416 - Requested Range Not Satisfiable                                          ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mirror.pcxlan.es/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                              ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://mrmarkuz.goip.de/mirror/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                       ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.
kmod-xt_ndpi-2.0.3-1.ns7.x86_6 FAILED
http://buck.goip.de/nethserver/7/updates/x86_64/Packages/kmod-xt_ndpi-2.0.3-1.ns7.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                  ]  0.0 B/s |    0 B  --:--:-- ETA
Trying other mirror.


Error downloading packages:
  kmod-xt_ndpi-2.0.3-1.ns7.x86_64: [Errno 256] No more mirrors to try.

Nethserver update fails ([Errno 14] HTTP Error 416 - Requested Range Not Satisfiable)
(Markus Neuberger) #2

Hi @pguerra,

do you use a proxy? You may try to delete cache or deactivate it

Found this thread:

https://www.centos.org/forums/viewtopic.php?t=4766


(Paul Guerra) #3

@mrmarkuz,

Thanks for the reply, I do not use a proxy and I did clear and disable cache. Still same results.


(Paul Guerra) #4

Solved:
Simply used wget to pull the file from mrmarkuz’s repository and ran rmp -Uvh.
yum throughs a warning about the rpmdb being modified outside of yum and completes all update just fine.