Nethserver trying to Connect to a DomainController

yes sure

Here’s an old screenshot showing the important “Promiscuous Mode” setting in virtualbox:

2017-09-09%2022-44-47

i need two adapters right ? i have set it like on the screenshot

No, not necessarily.

You’ll need a bridged interface (instead of host-only) to make it possible for other clients to reach the NSDC on the virtualized Nethserver.

yes i have it bridged

I tested it now with virtualbox 6.0 on win 10 and it finally worked.

Here are the network adapter settings:

grafik

What I did on the Nethserver VM:

  • set static ip for green interface
  • software updates
  • reboot
  • setup ad account provider

At first it didn’t work so I did following steps to make it work but I don’t know what exactly helped:

  • reboot the Nethserver VM or do a systemctl restart network
  • deactivate the VMWare network adapters in the Windows network settings and disable/enable the Virtualbox adapter (I use VMWare too)
  • change the adapter type in the virtualbox network settings to some other card (Intel …) and back again

i did this

I disabled/enabled the firewalls of the systems too. Maybe this did the trick.

On Nethserver you may do

shorewall clear

to disable the firewall and

signal-event firewall-adjust

for reenabling it.

I disabled the Windows firewall on my client too and enabled it again, maybe this resets some local adapters in a way.

For this step you have to shutdown the VM.

grafik

i think now the nethserver has no connection outside because i cant ping sites like google from the nethserver side how i can fix this

Check if the Network settings are correct. If you use a red interface, the gateway has to be entered there.
Does ping google.com work on the Nethserver directly? Do the clients get the right network settings via DHCP?

it is fixed now i can send pings to google

1 Like

If your problem is solved, please mark an answer as solution to help others and close the thread.

no it is not solved the native problem that i cant connect to the domain by client is not solved

if ein want to provision the domain i got this error in the end
Aufgabe mit Fehler abgeschlossen

Template /etc/krb5.conf #35 (Exit Status 1)
    expansion of /etc/krb5.conf failed

Please use following command to see more details about the error:

expand-template /etc/krb5.conf


and the second problem that when i try to add a client i can only use the netbios name not the full domain name and if i want to proceed with the login in the system say domain not found

the krb5 problem is fixed after an update

Is the full domain name resolvable from the client?

Does joining a client to Nethserver work?

Did you use correct login like DOMAIN\User?

It’s recommended to use a subdomain like AD.JANNIK.SITE as AD domain, see https://docs.nethserver.org/en/v7/accounts.html#dns-and-ad-domain

yes it is resolveble by nslookup but i cant ping the ip of the dc directly only the nethserver ip from the client

This is typical for not working/missing “promiscuous mode” in the virtualbox.

You may try to ping the Nethserver and a client from inside the NSDC:

NSDC has no ping so I just copied and removed it afterwards.

cp /usr/bin/ping /var/lib/machines/nsdc/usr/bin/
systemd-run -M nsdc -t /bin/bash
ping nethserver
ping client
rm /usr/bin/ping
exit

Here you can find some useful commands regarding NSDC and much more:

https://wiki.nethserver.org/doku.php?id=howto:useful_commands#samba4

Please follow these steps once again, try to reset the network adapters (local and virtual ones). Maybe reinstalling Virtualbox helps.

1 Like

it is fixed now only one change in the virtualbox setting Thank you for you Support

1 Like