Nethserver-subscription not working on expired nethserver enterprise

NethServer Version: NethServer release 7.4.1708 enterprise branded

I can not install nethserver subscription, because I’m stuck on enterprise branded nethserver. If I try on terminal:
yum install @nethserver-subscription
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
Group nethserver-subscription does not exist.
Error: Nothing to do

Also software center does not show a module for subscription.
What do I need to do to fall back to a standard nethserver installation for this expired enterprise server?

Only a shot in the dark, but perhaps you can set updates back to default and try again after it.

config setprop Secret '' SystemId ''
eorepo base centos-sclo-rh centos-sclo-sclo epel extras nethforge nethserver-base nethserver-updates updates

Are you sure you have a NethServer Enterprise installed?
Please verify if you have this rpm installed:

rpm -q nethserver-register

If the answer is yes:

rpm -e nethserver-register
config setprop httpd-admin logo ''
config setprop sysconfig ProductName NethServer
rm -f /etc/yum.repos.d/nethesis.repo
config delete nethupdate
config setprop Secret '' SystemId ''
eorepo base centos-sclo-rh centos-sclo-sclo epel extras nethforge nethserver-base nethserver-updates updates
signal-event nethserver-httpd-admin-update

Hint: I never tested such procedure :smiley:

yes I was on Enterprise.
Let the commands run.
Now my branding (Logo) is standard again.
Software center brought up some updates and I installed those.
Problem now: Software center does not show what is installed or could be installed, the list is empty.

How to bring back correct listing so I can choose to install nethserver.subscription?

Don’t know how to bring it back, but the subscription you can install manually:

yum install @nethserver-subscription

1 Like

you are right, I did so and subscription is available now! Thanks!

The software list is still empty!

You can try to rebuild the db, maybe it helps at your case to.

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum clean all
1 Like

I tried already before, but no change!

The whole process with deleting the old db?

@giacomo Can you help here?

yes all 3 lines you posted are neccessary

Please don’t! Unless the db is corrupted don’t execute such command!

@asl you probably have only metadata issues and you need to reconfigure the software center, just execute:

cat <<EOF > /etc/nethserver/pkginfo.conf
# This is the list of YUM repositories that have their groups listed
# on the Software Center UI page, through the pkginfo helper.
# One repository identifier per line

yum clean all

Feel free to contact Nethesis support if you still have any problem :wink:


@giacomo you solved it. The file /etc/nethserver/pkginfo.conf is differnet on enterprise edition. I changed back to what you posted and what I also could see on my other servers and I’m back to normal again.
so one more subscription is on it’s way now :slight_smile:

1 Like

Thanks @m.traeumner and @giacomo for the solution

BIG Thank you to @asl for buying a LASAGNA :stew: :stew: :stew:

I’m coming from an enterprise installation and that’s why there is already a token installed it looks like.
I assume that I need a procedure to remove the existing token so I can enter that one I just bought. My Subscription page looks like this:

How can I do that?

Is it the same problem?

Did you solve?

it is the same server but a 2nd problem from converting an enterprise installation to subscription model.
Not solved yet!

Just try also:

config delete nethupdate

Since you’re installation is a special case, please open a support request to Nethesis with SSH access to the machine and we will resolve it for you.

tried this initialization, but still the same. Will open a support ticket now and report back here…
Thank you

1 Like

Support told me what to do:

  config delete subscription

This will delete the subscription entered and in my case the old parts of the registration from privious enterprise branded installation.
Now I can enter a token.
Thanks to all.