Nethserver Squid Error


(Alex Carvalho) #1

Hi

I have an ERP system in the company that it generates report by the browser. Whenever it is generated appears this error.

the request or reply is too large.

I have configured proxy authentication, website filter


(Roberto Sitzia) #2

Hi @alexcsilva

seems to be a problem with report size generated by your ERP system.
Simply googling “squid the request or reply is too large” you can get some useful info but I suggest you to wait for a reply of a developer.


(Artem Fedai) #3

So @alexcsilva try to implement :
mkdir -p /etc/e-smith/templates-custom/etc/squid/squid.conf
cp /etc/e-smith/templates/etc/squid/squid.conf/90options /etc/e-smith/templates-custom/etc/squid/squid.conf/90options
add this line
request_body_max_size 0 KB
reply_body_max_size 0 KB
signal-event nethserver-squid-update
and try !


(Artem Fedai) #4

maybe it should be in a base config in next release.


(Alex Carvalho) #5

Thank you @Nas !


(Stefano) #6

I disagree

the solution posted by @sitz may work for @alexcsilva but be wrong/not necessary for the others

templates-custom is there for this reason :wink:


(Artem Fedai) #7

@zamboni you are wrong, this settings make unlimited requests, coz defaults it is 20KB , and people may use heavy sites like Topic Starter


(Stefano) #8

well, in my office I could want to limit that size… so, what’s wrong?

moreover, reading here:

http://wiki.squid-cache.org/SquidFaq/TroubleShooting#Why_do_I_get_.22The_request_or_reply_is_too_large.22_errors.3F

I see that those parameters are limited by default

finally, in such a case you may disagree with me, but before telling me I’m wrong, you’d show why (code, examples and so on) :wink:


(Roberto Sitzia) #9

@zamboni but I haven’t posted any solution :pensive:

Please post your public apologies to me :smile:


(Stefano) #10

you’re right… no lunch here and quite busy… my bad :smiley:

apologize to @sitz and to @nas (who proposed the custom template)