Nethserver-rspamd a new module

,

I tested nethserver-mail2-* on 2 servers, which were already running mailservers so I switched to mail2:

Both servers were fully updated with nethserver-mail2 2.0.0-1.45

One server with getmail and smarthost is just working without problems, except of:

I’ve gone through test case 2.2:

  • The sample file sample-virus-simple2.txt does not exist
  • sample-virus-nested.txt goes through and is then detected by my client

On the other server with direct mailing I get an error on screen and in /var/log/messages when I browse to “EMail Addresses” (MailAccount) in web UI.

Feb 18 23:05:56 nethserver httpd: [64] Cannot use lexical variable $view as a parameter name - File /usr/share/nethesis/NethServer/Module/MailAccount/User.php, line 80

I also have no dkim signature in the text field to enter it in the TXT record. This is the server where the “Junk” folder is reappearing, see this thread:

4 Likes

First of all, thank you for testing @mrmarkuz!

You’re right it’s probably a variant invented by me :innocent:

I noticed it too. Well it seems that test has really strict requirements to run, and we dropped support for it long time ago. So you can ignore the failure - the reason is explained here:

http://dev.nethserver.org/issues/2093

I’m fixing the test case!

Did you install the latest package (4 days ago) https://github.com/NethServer/dev/issues/5394#issuecomment-366203301 ?

I cannot see that message in my log: are you using a different PHP version (SCL)? Is it a warning or error? Is the web page correctly displayed or does it contain any error message? Did you increase the log verbosity by some means?

2 Likes

I recall a similar php warning with php7X and scl

2 Likes

Exactly, uninstalling nethserver-php-scl did the trick :+1:

  • MailAccount working
  • dkim signature is working

Thank you for your support! Will it be possible to use PHP7 with nethserver-mail2 ? It’s needed for moodle for instance.

We must not install PHP7 in httpd-admin instance. I think the correct approach is not replacing the default upstream (PHP5) version with the SCL one. Instead, setting up a php-fpm worker can help in maintaining different PHP versions - like nethserver-nextcloud does.

2 Likes

When I allowed to use php-mod with php7X for the whole server there were no issue but it is no more the case so I should forbbid it now.

Maybe i could think a solution for those use /var/www and want another php version.

1 Like

That would be nice as I really like the php-scl module but what about the php-fpm approach @davidep suggested? I have to find out how it works in nextcloud but if it would be possible to use other PHP versions without remi SCL it may be the better way…

When you install nethserver-php-scl you use

Php-fpm for virtualhost
Php-mod for the whole server (virtualhost and /var/www)

The goal could be to use only php-fpm

This the template to activate fpm https://github.com/stephdl/nethserver-php-scl/blob/ns7/root/etc/e-smith/templates/httpd/vhost-extra/15PhpScl_values

1 Like

DKIM depends on this package, right?

Yes dkim is part of nethserver-mail2-common

1 Like

I reinstalled the PHP scl module and MailAccount and dkim is still working. I’ll keep you updated if something goes wrong again…

1 Like

New version of rspamd, maybe we can do a reverse proxy of the webui of rspamd in tbe server-manager, the password issue seems solved. For the history issue I need to check, it is not part of the changelog

3 Likes

after updating the rspamd to new version i receive:
got IO timeout with server rspamd.com(88.99.142.95), after 3 retransmits

formerly it was okay

working smooth on my side, try to restart redis-rspamd and rspamd

systemctl restart rspamd-redis rspamd

as a side note, we agreed with @davidep to release by the nethserver repository the version of rspamd, obviously we need to test them

1 Like

Same timeouts here:

grep "got IO timeout" /var/log/maillog | wc -l
2199

@hucky @filippo_carletti sorry for my mistake…still in holiday :smiley:

the IO error is relative to fuzzy check database of rspamd.com (the main website)

according to this

https://groups.google.com/forum/#!topic/rspamd/OtizdoxmLFs
https://groups.google.com/forum/#!topic/rspamd/5_Zc2Ynm4Dc

it could be a firewall issue (UDP 11335) or a routage problem, please try it, I cannot reproduce it.

PS…time to play with my daughter :slight_smile:

2 Likes

i see that the error comes from the controller:

21.2.2018, 11:00:03 controller 17793 csession c2ac55 got IO timeout with server rspamd.com(88.99.142.95), after 3 retransmits

but in any case it seems not to be every time it makes the check.

i will try to figure out more.

PS Good Reason to do a break, wish you a nice time with your daughter :+1::+1::+1::+1::+1:

1 Like

Just added p3scan module to the mail2 bundle.

New test cases 1.4 and 2.4, added here /cc @quality_team

https://github.com/NethServer/dev/issues/5394#issuecomment-367295232

Updated docs

http://docs.nethserver.org/en/latest/mail2.html#from-pop3-proxy-module

This issue requires QA tests too:

2 Likes

A post was split to a new topic: Builtin block port 25

so have figured out the problem with the error of the controller, seems that a synch over the proxy not work.
so i do bypass the proxy for the rspamd domain and it seems to work now

1 Like