Nethserver-rh-php73-php-fpm

I saw that we have a need about php73, from several sources, readable on this forum and by private email, people wants more than php72.

I would like to propose to add rh-php73 to nethserver-httpd-virtualhosts

What do you think ?

3 Likes

I’m ok with it, PHP 7.3 will be supported for all 2021: https://access.redhat.com/support/policy/updates/rhscl-rhel7

2 Likes

I created the fork of nethserver-rh-php73-fpm and I transmitted the the repo’s ownership to the NethServer organisation.

Could you accept and check travis builds it well @dev_team

Next step is to add rh-php73 to nethserver-httpd-virtualhosts

2 Likes

Travis build is ok: https://travis-ci.com/github/NethServer/nethserver-rh-php73-php-fpm

1 Like
2 Likes

It has been released, nethserver-httpd-virtualhosts can use now rh-php73

2 Likes

It is possible to have php 7.4 too?

For now no, you should use my contrib, nethserver-php-scl which has not been ported to cockpit and it won’t been I think.

Maybe we could imagine to fork nethserver-http-* to have php74 but I am not sure of the benefits

Actually rh-php74 doesn’t exist but when available it will be added

1 Like