Nethserver-rh-php71-php-fpm Error when installing Self service password

NethServer Version: 7.9.209
Module: Self Service Password

Hello all, i am trying to install Self service password but i am geting this error

Error: Package: nethserver-self-service-password-0.1-4.ns7.noarch (danb35)
           Requires: nethserver-rh-php71-php-fpm

i have trying running yun install nethserver-rh-php71-php-fpm but am getting no package. how do i resolve this error


I think PHP 7.1 went EOL a while back, so it likely needs updating to use a more-current version. Can’t fix it right now, but maybe this evening.

Edit: If you want to use LLNG, it should handle password changes as well, but I’ll admit I haven’t tested that feature yet.


ok, please share once fixed.

Updated RPM should be out at the repo in about 20 minutes.

1 Like

that one erro seems resolves, but now getting an error

Error: Package: nethserver-self-service-password-0.2-1.ns7.noarch (danb35)
           Requires: self-service-password
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

when running yum --enablerepo=danb35 install nethserver-self-service-password

Have you added the LTB project repo as described in the wiki?

yap, that process has been followed. maybe try doing a clean install on your end and share findings.

I did before pushing the RPM to the repo. What happens if you try yum --enablerepo=danb35,ltb-project-noarch install nethserver-self-service-password?

that one worked like a charm.

i guess the documentation needs to be updated

Perhaps. What’s curious is that it worked on my test system (a completely clean installation) without specifying that repo. Do you have a subscription on your server?

no i dont have a subscription

Again, strange. Wouldn’t hurt to update the wiki though.

BTW, I trust you’re already aware that this has become largely redundant since its release, due to this:

The only thing SSP does that this doesn’t is (when using OpenLDAP) allow an email token to reset the password. And, IMO, it looks nicer.

1 Like

I was slighlty aware it might be possible with the cockpit, but thanks, that sheds some light.

Overall, the Email Token is the main thing and reason for instaling it in the first place. i wish Nethserver had it built-in

IIRC (and it been a while, had to do with arm kernels not being updated ) when-ever there is a software-repos-save event , which usually only happens with a new nethsever point release, all (3th party) repositories are disabled. Only difference in behavior between a subscription and a *non-*subscription is on a *non-*subscription nethforge keeps being enabled:

Since nethserver-subscription 3.8.6 (17 feb 2021) a user can change the default behavior:

A packager / 3th party nethserver-repository provider could hook in to expansion of /etc/nethserver/eorepo.conf (like I did for the CentOS-arm-kernel repository) Though IMHO it would be inappropriate to do so for subscription systems. And more broader keeps the question open how to govern this.
(I mean: Consulted @davidep to keep the (official CentOS) repository for arm-kernels enabled, which seems a no-brainer, as it intrudes some core parts of nethserver-base / nethserver-subscription)

1 Like