NethServer on KVM issue

I run latest NethServer as a VM on my unRAID server.
I have noticed this months ago, but to be honest never bothered to report it (it is minor).

I have noticed that if I set NS machine to use anything newer than Q35-4.2, it freezes after a few minutes/seconds.
It boots the system, it enabled the web interface, but then console is frozen (cursor static) and web interface dies.

It is not an issue to keep this machine with Q35-4.2, but if it is something that can be fixed, why not.

Hi Nick,
currently i am no expert nor newby of KVM on unRAID.

refers to? VM “type”?

Moreover: do you have any other CentOS 7-based VM on your unRAID? Is there any suggestion/best practices for this OS as KVM Guest on unRAID?

Well in configuration it refers as “machine”.
It is the chipset emulation used.

No I don’t have other CentOS 7 VMs.

Did somebody else test it.



I just tried testing a NethServer install on KVM with the Q35 BIOS latest (at least 6.0!)

Just finished install, so far nothing irregular. Now creating some “load” with updating…

1 Like

I still wonder if it is related to specific host hardware or specific NS services running (“pushing” the virtual chipset in the right places)…

Hi Nick

As said and shown in the screenshots, I’m using Q35 / 60(+)…
It could be the KVM implementation in UNRAID uses an older Version than my Proxmox (Top up to date!)…
Note: I’m using a KVM-64 CPU here, not “host”…
This should make the hardware practically negliciable, this even allows a Windows10 to run with an AMD or Intel underneath - no blue screens!
Windows does not even realize the CPU has changed…

A good idea may be to find out the used versions - I’ll need to check what Proxmox is using…

As to the VM:

So far nothing unstable…

With 4 GB RAM and 4 CPU cores (The hardware is a almost 10 year old HP Proliant ML110 G7…) it’s quite fast, too.


My 2 cents

Packet Versions used by my Version of Proxmox (7.0.13):

  • proxmox-ve: 7.0-2 (running kernel: 5.11.22-5-pve)
  • pve-manager: 7.0-13 (running version: 7.0-13/7aa7e488)
  • pve-kernel-helper: 7.1-2
  • pve-kernel-5.11: 7.0-8
  • pve-kernel-5.11.22-5-pve: 5.11.22-10
  • pve-kernel-5.11.22-4-pve: 5.11.22-9
  • pve-kernel-5.11.22-3-pve: 5.11.22-7
  • pve-kernel-5.11.22-1-pve: 5.11.22-2
  • ceph-fuse: 15.2.13-pve1
  • corosync: 3.1.5-pve1
  • criu: 3.15-1+pve-1
  • glusterfs-client: 9.2-1
  • ifupdown2: 3.1.0-1+pmx3
  • ksm-control-daemon: 1.4-1
  • libjs-extjs: 7.0.0-1
  • libknet1: 1.22-pve1
  • libproxmox-acme-perl: 1.4.0
  • libproxmox-backup-qemu0: 1.2.0-1
  • libpve-access-control: 7.0-5
  • libpve-apiclient-perl: 3.2-1
  • libpve-common-perl: 7.0-10
  • libpve-guest-common-perl: 4.0-2
  • libpve-http-server-perl: 4.0-3
  • libpve-storage-perl: 7.0-12
  • libspice-server1: 0.14.3-2.1
  • lvm2: 2.03.11-2.1
  • lxc-pve: 4.0.9-4
  • lxcfs: 4.0.8-pve2
  • novnc-pve: 1.2.0-3
  • proxmox-backup-client: 2.0.11-1
  • proxmox-backup-file-restore: 2.0.11-1
  • proxmox-mini-journalreader: 1.2-1
  • proxmox-widget-toolkit: 3.3-6
  • pve-cluster: 7.0-3
  • pve-container: 4.1-1
  • pve-docs: 7.0-5
  • pve-edk2-firmware: 3.20210831-1
  • pve-firewall: 4.2-4
  • pve-firmware: 3.3-2
  • pve-ha-manager: 3.3-1
  • pve-i18n: 2.5-1
  • pve-qemu-kvm: 6.0.0-4
  • pve-xtermjs: 4.12.0-1
  • qemu-server: 7.0-16
  • smartmontools: 7.2-1
  • spiceterm: 3.2-2
  • vncterm: 1.7-1
  • zfsutils-linux: 2.0.5-pve1
1 Like

Not sure of KVM version in UNRAID (it also updated a few days ago in latest RC), but I see latest Q35 is 6.1, so definitely not an old version of KVM.

I don’t use an emulated CPU (I use the host, an i7 4771), but will definitely try that.


When using KVM64 CPU, be sure to activate the AESNI option, otherwise your VPNs will be slow…


The reason why I use KVM64 for all my 30 clients and almost all VMs (Only one exception: nested Virtualization of VMware ESXi in Proxmox to run 2 Novell Netware servers my client needs for legal reasons (archive available)) is that this increases flexibility, especially for Windows systems.
This enables me to live migrate VMs between almost any hardware without issues, like Windows needing reactivation or relicensing… :slight_smile:

1 Like

I am having second thoughts on switching to QEMU64 CPU (maybe I will for testing only), as I really care more about not having a CPU bottleneck or limiting my CPU flags (UNRAID doesn’t allow configuration of QEMU64 emulated CPU at least through GUI - proxmox is specialized in VM hosting), than using a new version of the (same) emulated chipset.

I might do some testing in the weekend though to see if we are looking at the right direction.

1 Like