Nethserver-madsonic needs testers

Ola something new to play with : nethserver-madsonic for NS7

madsonic is a music streamer by a web application ->

The application is free during one month, after that if you want to use it on your mobile phone, you must pay. However I use it for free in my browser.

yum install

go to https://YOURIP/madsonic but also before you must let music there by a samba access

the application can be used also by ldap/samba4 AD @dnutan would you please give us the good settings for that, I saw you are good :slight_smile:

you have some db values

[root@NS7DEV7 ~]# config show madsonic

for example

config setprop madsonic Name music
signal-event nethserver-madsonic-update

then madsonic is reachable to https://YOURIP/music

A thin panel is available in the configuration area, you can set the web access (private/public), the status (enabled/disabled) and the users allowed in samba share (to manage the media folder). Of course if SambaAD is not installed, samba is in a guest access mode.


Telling the true I don’t know LDAP / AD. So better if someone else checks it or adds a more restrictive LDAP filter.

###OpenLDAP (local account provider)

  • LDAP URL: ldap://,dc=nh
  • LDAP search filter: (uid={0})
  • LDAP group searchBase: ou=groups
  • LDAP group filter: (memberuid={0})
  • LDAP group role attribute: ou
  • LDAP manager DN: cn=ldapservice,dc=directory,dc=nh
  • Password: look for bind password under Status -> Domain accounts, from NethServer’s server-manager.
  • Automatically create users in Madsonic: checked

like me for coding, I crash the code all the time :stuck_out_tongue:


I was able to install and set it up to authenticate from AD, but I get this and http 500 when it process the login and lands in this page:

on the madsonic log I can only see this
[2017-03-19 01:06:34,302] INFO MadsonicLdapBindAuthenticator - cloned from default user ‘jorge’ for DN cn=jorge,cn=Users

Same error here :sweat:

just got it working
i will share a print screen with my settings for AD

1 Like

The settings that worked for me

able to login! :slight_smile:

@Jorge_Soares @dnutan follow this link there is a bash command to retrieve all ldap settings, and particularly

“bindPassword” : “secret”,
“bindDN” : “DPNET\VM5$”

like this if you change the password of admin, you don’t need to change it in madsonic.

please, fix the ldap issue at

version for ns6

yum install

see the first post for settings, no differences

Free Subsonic mobile apps should work with Madsonic server without Premium subscriptions.
I was planning to add MPD to Nethserver, but will try Madsonic first.

1 Like

Sorry but at the end of your free month, the subsonic app will stop to work, you have to pay.

I love this software :stuck_out_tongue:

In another hand I did a rpm for ampache, but you have to use the web installer, i didn’t make the nethserver integration. See the wiki

released for ns6 and ns7

1 Like