Nethserver Install issues

NethServer Version: 7.3

I have been here before, I tried many versions ago to install Nethserver from a USB stick on the an HP microserver and failed. I eventually got it running by installing CentOS and then nethserver on top of that but it was painful.

I ran it and played with it for some time and then other “life” issues got in the way and I stopped playing with it for a while.

I am now back and have downloaded the new release, alas it still will not install from USB.

I get the Nethserver Splash screen, choose to install nethserver and initially it all looks to be working OK, lots of lines of text messages on screen until it gets to a point that says
loop:module loaded

After this there is a long pause- several minutes, and then pages and pages of error message relating to timeout scripts.

After that the screen clears and a few more lines of text and a message that says

kickstart file /run/install.ks.cfg missing

then nothing more.

I used rufus to create the bootable USB.

I have tried to install CentOS from the same USB, that works and I can get a root login, but the yum command will not work, so far.

Also if I go down the CentOS route it will not RAID the two drives, not a total deal breaker but I would like to RAID the drives if possible.

Any thoughts ?

Do you have your microserver connected to a working internet connection? NethServer checks during install where to get packages.

I have a HP G7 microserver myself and there was absolutely no issue installing NS7. (I have installed it on 2 different HP G7 microservers and both are running rocksolid.)
Installing NS using softraid is supported if you choose manual or interactive install.

Are you sure your USB stick is ok? I created an USB stick using dd:
You can find more info in how to do this here:
Make sure your IF is the NethServer7 ISO image and OF is the USB drive.

dd if=/location/of/iso/NethServer7.ISO of=/dev/sdb

Please, use dd on linux to create the key, as documented in the manual:

This is not true, internet access is not required during install, all software is available in the cd iso image.

Even unattended mode will default to RAID1 if there are two disks installed.

1 Like

@filippo_carletti thnx for the clarification. I mentioned the internet connection because of my own observation. I tried to start up a NS7 (rc2 I think) and it failed. I suspected it to be the lack of internet connection, but not 100% sure. I do know that with a (decent) internet connection the install went well.

Even though the unattended install supports raid1, I would choose the interactive or manual install because then you know for sure the partitioning is how you want it.

I did this once and I recall that installing unattended without network access… does not set the adapter to dhcp and sets it to a default of because even after turning on the adapter and rebooting it wouldn’t take an address from the dhcp server on the subnet and would just keep

Wasn’t an issue because I just set an ip once I turned the adapter on instead of diddling around changing the network subnet just to get to the gui.

hi @Loboexe

more than 100 days ago I had the same problems/ the same behaviour and I think filippo is right!

And if you use windows - under rufus you have also the possibility to choose dd.


This is unrelated to using dd, but make sure that you configure the partitions manually if you have a raid controller in use because in the installation sequence it’s defaulted to software raid 1. I had to reinstall after my first install to find what had happened from not paying attention to my first install on a new box.

1 Like

Been busy, so only just got chance to push on with this tonight, I have got further (I think)

I went back to the start. Formatted the USB again, used Win32Disk to make the image and then tried again.

I now get through to the CentOS install screen, I followed the instructions show in this YouTube video

Now first oddity, I have 5 Ethernet interfaces on this microserver. The single Ethernet on the motherboard and a 4 port card I have fitted for firewall/router use when I get Nethserver up and running.

All the ports were recognised in the CentOS install phase, and I turned off the 4 ports on the card leaving the Ethernet port on the motherboard on.

I completed the install process as per the video and rebooted.

Oddity 2, When I log in using the root account and the password I set in the install I do not get the
*******Welcome to nethserver *******

not sure if this is important or a clue to a problem.

All Ethernet ports are down and have no associated IP address.

I have given the single Ethernet port an IP in the address range of my router but nothing can ping it and it cannot ping anything else , destination unreachable

Any thoughts ?

If you log in on the server itself, what IP address does the server have on the configured interface?
As soon you found the IP address, connect a pc/laptop to that interface with an IP in the same range and try to connect to the webinterface. It can perfectly be that the interface has an IP address of instead of the IP you configured during install.
As soon you can reach the webinterface, you can configure all other interfaces in the networking section.

How do I run up a local copy of the server, I can only access it via the

Whit logging in on the server itself (using an attached monitor and keyboard) you can find out what IP address is actually configured. Anaconda (the install environment used by CentOS) sometimes acts quite strange when configuring network interfaces.
Find out through the commandline what IP is configured and then configure a pc/laptop in the same subnet and connect it with the network interface you know the IP address of. (a switch in between is the easiest way)
As soon you have the pc/laptop connected and can reach the server, you can fire up a webbrowser on the pc/laptop and head over to the NethServer webinterface. Then you will get the initial configuration wizard. After that you can go to the network section of the admin web interface and configure the network interfaces as you want them.

That’s what I did.

I have configured the single Ethernet port (not one on the 4 port card) to be and it is patched through a switch to the rest of my network.

My router is, my PC is .121

Tonight I rebooted it to see if I could get further…

First, I got the splash screen; progress, I logged on and as you hinted the settings I made had been overwritten and one of the 4 ports on the card had been set to

Unfortunately this clashes with the IP of my one of my switches.

I set the port to down, and the single port to up (it was down) and set the IP of this back to .200. If I try to ping any port on my LAN it say’s destination unreachable, almost like it is on a different subnet. Also nothing on my LAN can ping it and it does not appear as a connected device on my router.

I set the port that the install chose (one on the card ) to 201, Like .200 it cannot ping anything on my LAN (destination unreachable) and nothing can see it. The two ports can ping each other however.

Is it OK to change the IP (used in the install .1.1) using ifconfig and not the web interface or will this break the install until I do it through the web interface.

Needless to say this is very frustrating !

Yes, change the adapter to the ip you want with ifconfig from the console.

@Loboexe, can you confirm that you can confirgure and use NethServer in a normal way now?
I know, it is a pain in the behind, but unfortunately this behavior is an Anaconda issue and the only thing we can do about it is pointing upstream Anaconda devs with this.


Please read:
The IP set during a clean installation is changed after the first reboot

1 Like

Hi Rob

I followed the video found here

I think that follows the instructions on the document site. It seems to be accurate. The first time through I got the issues with trying to recover space on the drives as highlighted in the video, if you ignore this and just do everything else it seems to work as far as installing all the software

The issues I have that, even though in the graphical install process under Network it does see all 5 network ports (the 4 on the card and the built in one on the motherboard) when I choose the single port to be connected and I set it to an IP I know is not used, after the install is complete it does not use that port and goes to one of the 4 on the card and uses the .1.1 address.

After that, no matter what I do I cannot see the port, the web interface or ping it, even if I change the address after the install using the CLI.

As explained, I have now set up one of the ports on the card as a second address. This too is invisible to the rest of my network and the rest of my network is unreachable from the nethserver, but the two ports can ping each other and they are connected via the same switch as all the other devices are.

Could this be a firewall thing ?, is the nethserver firewall preventing any comms in or out ? it feels like that could be something to look at.

For info my Microserver is a 54L, with 16 Gb of RAM and two 1 Tb drives fitted. I have had an older version of Nethserver running on it but as I said for one reason or another, I stopped using it and waited for the version 7 to be released before trying again.

Hi @Loboexe,
As far as I know, as long you haven’t set any interface to red (external) there are no ports blocked and no firewall rules are set.
I have exactly the same server as you have: a Gen7 HP microserver. I installed NS7 on both N40L and N54L and also encoutered the IP problems you describe.

I fixed this by investigating what the IP address was so I could configure my laptop with an IP address in the same subnet. Then connecting the server to a dumb switch and connect my laptop to the same switch. This way I was able to reach the NS webinterface and configure all network interfaces as I needed, changing the interface which I was connected to as last. (you will get disconnected if you change that interface first… :wink: )

After that I connected the server to the network and could configure the rest of the settings and add modules.
It is annoying behaviour, but again, unfortunately this is an upstream problem that we need to deal with.

Hi Rob

Thanks for your continued assistance. The more I look into this the more I think it may be my main switch.

Like you, I dug out a little dumb 6 point switch and connected the server to that and then a laptop and now I can access the server, it was on 1.1 and using one of the ports on the card. I was able to get into the nethserver network tool and allocate .200 to the single port and disable the card port.

I tested that I could access the server on the .200 port, success !

Now, I unplugged the server from the dumb switch and moved it to my main switch. Nothing, same as before network unavailable…

Swapped it back, still OK

Moved my laptop to my main switch and it cannot see anything, move it back nothing.

I tried linking the dumb router to my main switch, nothing!

Everything IS IN THE SAME SUBNET how is this not working ?

not sure where to go from here…

Is it a smart switch? Meaning does it have management software for vlans, mirroring and such?



It was the switch, not sure why as looking on the config there was nothing there out of the ordinary. I did have some VLAN’s set up some time ago but had removed them, or at least I thought I had and I could not see any in the config.

The only other thing is I updated the firmware a few weeks ago, but again nothing looked screwy on the config, however a factory reset fixed it all.

Thanks for everybody’s input - it look’s like I can now ping the server at least

now to see if I can configure it.