Nethserver + IBackup: problems with libffi

So one of my CentOS 6.7 servers I decided to upgrade to Nethservers. Originally on my CentOS 6.7 server I was running IBackup and had installed it just fine.

I use IBackup on alot of my servers.

To find out how to install IBackup you can read the following -

During running the EZ-Installer I ran in to the following issue:

yum install -q -y gcc gmp-devel python-devel libffi-devel openssl-devel
Package gcc-4.4.7-16.el6.x86_64 already installed and latest version
Package gmp-devel-4.3.1-7.el6_2.2.x86_64 already installed and latest version
Package python-devel-2.6.6-64.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-42.el6_7.1.x86_64 already installed and latest version
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

     1. You have an upgrade for libffi which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libffi of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libffi.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libffi installed, but
        yum can only see an upgrade for one of those arcitectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libffi installed already.
        You can use "yum check" to get yum show these errors. can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

   Protected multilib versions: libffi-3.0.5-3.2.el6.i686 != libffi-3.0.10-1.x86_64

So before I do something that messes my setup up I wanted to see if someone could help me to find a solution to allow me to still use IBackup.

Thanks for your help,

IIRC libffi is in NethServer repositories as a SOGo dependency:

If you don’t plan to use SOGo you can safely install the upstream libffi package.

I don’t know if SOGo wants to fix this issue. I think we should move nethserver-sogo out of the NethServer base repository, in NethForge or similar and pull SOGo RPMs directly from the repository above.

Edit: the workaround could be adding an exclude=libffi line under [nethserver-base] in /etc/yum.repos.d/NethServer.repo.

1 Like

My 2 cent :smile:
As for all additional features, they should have their own packages.

In reference to sogo

hope this is a different machine and not your production one and, above all, not exposed to wan in any way.

I see also that

Step 1: Python 2.7 installation

IBackup - DataCenter Edition needs Python 2.7 to run. CentOS systems usually do not have Python 2.7 installed. So, the first step on most CentOS systems is to download and install Python 2.7.

if you need python > 2.6 on a centos setup, the best way is to use the softwarecollections approach… upgrading python is not an option (will break yum, for example) and installing it outside yum/rpm stack is a PITA to maintain…

moreover, the necessity to install developments tools on a production server is just searching security installing a security door in a drywall wall :wink:

Yes, It is important to realize dev tools are an open security hole. But those development items can also be removed after the application// program is compiled / installed just as easy as they were install.

Always important to be security minded tho.


There is an easy script / bin file they built that helps you install it. In the script it downloads Python and compiles it and then uses it to install IBackup. They also show you how to manually install IBackup DataCenter Edition as well.

I saw…

as I told you, the issue with this approach is that you have a python 2.7 install on your server that you can’t maintain… if it were bugged, your backup procedure could be too…

and, IMVHO, you’d always have the full control on what is installed/where is installed on your server

Sorry Guys it took me so long to respond. Family comes first… So I haven’t had a chance to get this ago. I have two servers that are NethServer. One will be using SOGo and the other one will not.

So I am guessing that to one with out SOGo I will be able to safetly install the upstream libffi package. Like you said above.

I guess I will look closer on how to get it going for that one, but if I have one that has SOGo, which I do… what can I do to get SOGo and iBackup to coexist? Let me know.


Perhaps you could try to install SOGo then add iBackup. I hope iBackup does not require a specific version of libffi.