NethServer Hotsync slave restore

high-availability

(Wayne Bilger) #1

Continuing the discussion from NethServer Hotsync [Needs Testing]:

Sorry, was off for a bit, but have tested this many times now, and I am getting the Nextcloud apps after promoting slave to master. Looks good!

But, I have one issue still;

Cockpit is not synced.
I tried installing cockpit again, and it still does not work, unable to connect page on port 9090.
I tried uninstalling, rebooting, reinstalling, still nothing.
Not a big deal, but it was an easy way to disable hotsync on new master so I do not receive an Hotsync error email every 15 minutes.

What is the recommended way to disable hotsync on temp new Master while hotsync is not running as there is no slave?


(Giacomo Sanchietti) #2

This is because Cockpit is published inside the testing repositories.

I didn’t understand very well the question. Could you give us an example?

Maybe @alep and @Stll0 can help here.


(Alessandro Polidori) #3

To disable:

# config setprop hotsync status disabled
# signal-event nethserver-hotsync-update

the documentation update will soon be available :wink:


(Wayne Bilger) #4

Any idea why I cannot install Cockpit on the slave (new master)?


(Giacomo Sanchietti) #5

Of course :wink: Just execute the second command from here: http://docs.nethserver.org/en/v7/hotsync.html#installation


(Wayne Bilger) #6

Yes, I’ve tried that.
I had cockpit running on original master, works no problem.
Then after restore of slave to master, as you said, cockpit is not sync’d, so I install cockpit on new master and it will not run, I get nothing on port 9090.
NS is installed on a VM, so I even tried rolling back a snapshot on slave and installing it on before promotion to master, and it works.