Nethserver Duplicity backup Issue

NethServer Version: 7
Module: Data-Backup
I am data backup issue, i have mounted CIFS share directory but backup is not working.

[root@pdc ~]# /etc/e-smith/events/actions/mount-config getprop backup-data VFSType

-bash: /etc/e-smith/events/actions/mount-: No such file or directory

Why this is coming ? and tell me the best possible way out.




Why use CIFS - a Windows Share - for a Linux Box and it’s backup?
CIFS uses much more CPU resources than eg NFS, which is like a native language for UNIX/Linux. Speaking a foreign language is always harder than speaking your native tongue!

-> Try switching over to use NFS!

BTW: NEVER mount the Backup Share!
The Backup programm will do that.
If it’s already mounted, you’ll get an error - and no backup!

My 2 cents


Why would anyone need permissions to access a backup share?

Not a valid reason, IMHO…

NFS can be locked down to a single IP.
And in the backup folder, there’s NOTHING for any other user except for Sysadmins there…

The only valid reason is a NAS or Storage without NFS option…

My 2 cents

Avoiding delete and unwanted sabotage? The (l)users are too many, the (l)users are too strong.

Sorry, but the quoted command is malformed. Maybe effect of copy/paste.

The reason you’re getting that message is that you’re combining a partial directory name (/etc/e-smith/events/actions/mount-, which doesn’t exist) with a command (config) that doesn’t live there, or in any of the actual directories that are similar to that. Why are you running the command that way? And what actual error do you get when the backup tries to run?

…or one that uses NFS for other purposes as well, and doesn’t have sufficiently-granular IP access controls. Or simple user preference–that’s valid too.


this is a time-out problem on CIF-shares.Sorry, I do not find the old thread - but when I started using Nethserver arround 2015 / 2016 I had exactly the same problem. I switched to NFS, Amazon S3 and a USB-Disk.

Do not use CIFs for regular backups - it is just fine for sending a few data …

I hope this helps.
Best regards