NethServer Docker 1.0.1 released

Everything sounds better in Italian :blush:

1 Like

Just execute make after cloning the repo. If you really want to test it, you need to setup a repo, something like this:

mkdir myrepo
cd myrepo
creatererpo -g groups.xml

But travis will do the job for you, no worry :slight_smile:

1 Like

That’s a really great news …
i would finally switch to nethserver.

My best compliment. Wonderful work!

1 Like

@mrmarkuz I updated to 1.0.1 but the aerial network has not been created.

Strangely enough, the log said :

esmith::event[24754]: Action: /etc/e-smith/events/nethserver-docker-update/S20nethserver-docker-create-aeria SUCCESS [0.074652]

I tried to yum reinstall nethserver-docker : no change.

Finally I issued manually the command found in the script :

docker network create -d devplayer0/net-dhcp:latest --ipam-driver null -o bridge=br0 aeria

It worked. Dunno what happened. I had installed the DHCP plugin before but it was deactivated (no network using it) when I updated.

Other side effect : my pihole container lost some configuration settings (DNS servers and local resolution).

Did you enable the Aeria network?

I am going to check but it should be persistent…

1 Like

My bad. I was unaware of this. Sorry.

2 Likes

We have made some internal changes

  • portainer is disabled by default : We would like a dependency for a lot of usage, I might not need portainer, but it is a big plus if I can install it quickly with a command line

  • Aeria is disabled by default : We cannot presume on which bridge you want to run aeria, you could have several green NIC, how we could decide what is the good one, the first, not sure. The easier solution for us is to ask to create manually the bridge and by the command line set the good bridge name to bridgeAeria

6 Likes

BTW the docker-compose tool that is installed is really old and has a bug for docker-compose.yml files version > 3.3 (it pretends to not support them even if it should).

Installing the latest stable version (at the time of writing) can be done easily :

curl -L "https://github.com/docker/compose/releases/download/1.25.5/docker-compose-$(uname -s)-$(uname -m)" -o /usr/bin/docker-compose
chmod +x /usr/bin/docker-compose

Have fun

3 Likes

Great job done by the pair of you. Now I can free up ram on dev PC and put docker on the Nethserver.
Thanks for getting the hard yards done.

1 Like

Kudos to both for pulling this out, much needed. These are the situations where you ask yourself why the :heart: are limited to one per person :wink:

And at least a beer to each one of you at next meeting is the minimum :slight_smile:

6 Likes