Nethserver-collabora CODE testing and discussion

Found some info, seems you need a key file even if ssl is disabled i.e HTTP is used:

Also managed to build loolwsd from source but it’s not working yet, curl pit seems to be setting up the jail chroot in a proper way. This is done quite unconventional by running loolwsd-systemplate-setup script at install (%post):

Need to figure out what it does…

1 Like

Hey @mrmarkuz, did I say thank for that module ?

I successfully installed it using the manual installation following your first post but recently upgraded to NC 15, which broke the installation. Now I get a white page when I create or open a document.

I tried to install your nethserver-collabora module but same result.

The admin page leads to NC’s usual file page, like if there is a redirect.

In Apache’s access_log I see 500 errors when acceding to the richdocumentsapp (when opening a document file).

Do you observe this behaviour as well ?
Matt

2 Likes

First, thanks for testing!

I think I could reproduce it. Fresh install worked but updating is a problem.
After updating CODE from 3.4 to 4.0 the updated /etc/loolwsd/loolwsd.xml (including the new paths to collabora 6 instead of 5.3) is saved as loolwsd.xml.rpmnew but loolwsd continues working with the old loolwsd.xml and that leads to the white screen.

Workaround until I can provide an updated module, I’ll update the wiki too.

mv /etc/loolwsd/loolwsd.xml /etc/loolwsd/loolwsd.xml.old
mv /etc/loolwsd/loolwsd.xml.rpmnew /etc/loolwsd/loolwsd.xml`
signal-event nethserver-collabora-update

As you use a new default config file, you have to set the password again, see the wiki

I couldn’t reproduce this one, do you use a vhost for nextcloud?

1 Like

Everything working, THANKS :slight_smile:

Indeed. Using the “real” server name worked.

Curious if this is currently installing CODE 4.0–document editing using the mobile client apps would be a big win.

Yes, it should use the newest one from collabora repo.

1 Like

Cool, once 7.6 hits the subscription repo I’ll give it a try.

Why does the wiki call for yum install nethserver-nextcloud as a separate step? Seems it’d be simpler to just have it as a Requires: for nethserver-collabora.

1 Like

You are right, it’s the same with onlyoffice.
The intention was to be extra flexible and have the possibility to have them on separate machines.

Ah, that does make some sense too–hadn’t thought about that scenario.

Or if other applications supporting Collabora CODE are integrated in the future.

1 Like

We have a testing machine running collabora integrated with Nextcloud.
It’s not rock solid, but it works for simple documents.

An alpha release it’s in my agenda since long time, let’s see if now it is stable enough :slight_smile:

I hope also webtop will use it. Ehi @webtop_team any news on it?

2 Likes

That’s also my experience : ok for small documents but even integrating a picture or two leads to annoying display and functional bugs. Much better than nothing though.

I wish a full HTML5 editor even with less features (except collaborative editing which is a must) exists.

1 Like

Have you tried OnlyOffice as well? It seems to deal well with more complex documents.

Probably OnlyOffice works a little better, but it can’t be installed on NS without replacing the default nodejs stack. :frowning:

…or just installing the nethserver-onlyoffice module?

Onlyoffice wiki recommends to install a newer nodejs now:

https://wiki.nethserver.org/doku.php?id=onlyoffice#install_nodejs_repo

You may disable spellchecker or use higher nodejs version to not have high CPU load, see Nextcloud Onlyoffice Nodejs and npm version

1 Like

Ah, that’s what I get for skimming.

1 Like

Do you see a problem here?

IIRC some of my howtos recommend installing newer nodejs too.

Yes: we should not replace RHEL stack otherwise we loose all the security updates.

To use a newer nodejs version, we should use SCL. But I didn’t try onlyoffice with it.

1 Like

@LayLow already tried that here, but the onlyoffice documentserver requires nodejs and rh-nodejs8 conflicts with nodejs.
It seems to be a known bug: https://bugzilla.redhat.com/show_bug.cgi?id=1637922

1 Like