Nethserver Breakdown Randomly

I installed Nethserver since two weeks, just configure the green and red interfaces and add the DHCP and the monitoring service but the Nethserver system keep disconnect randomly within some hours, How could I fix this issue?

Can you provide some more details?
By disconnecting do you mean NethServer disconnects from Internet or from the LAN, or it just reboots…
Any meaningful errors in /var/log/messages ?
Which version of NethServer is installed?

Hello,

First of all thanks for your kind respond, the gateway is core-i3 2100 3.1
GHZ with 8 GB ram with two Network Cards one built in (green) and the other
is dedicated (Red) and it’s built to service around 100 devices.

The problem is the Nethserver goes down randomly within some hours:
can’t ping from in to out or from out to in, even the screen goes blank
without an respond, for the user they are shown connected to the server but
not to the internet with yellow triangle icon even if try to give it a
static ip nothing happened.

Looking forward to get your respond.
Best Regards

Hi @ismaielsami ,

are the two nics conected to the same switch in the same lan?

Hi,

Nope,
the red is connected to the ISP and the green is connected to the LAN
switch.

Hi,

Is the built-in NIC in the HCL of RedHat?

Try to verify/replace the patch cord between GREEN and SW.
Also, change the port in SW.
Can you put another NIC in your HW instead of the built-in NIC?
I think your problem comes from the HW.

I tried before, to change all the patch cords or switch the NIC but nothing
changed and the server just freeze and back to work until press the restart
button.

In the var/log/message I got nothing show why it’s go down, here are some
of the logs from yesterday:

1st breakdown freeze between 06:39:21 and 09:19:07 :
Aug 17 06:39:21 host dnsmasq-dhcp[2608]: DHCPACK(eth0) 192.168.1.220
cc:78:55:f6:6f:ef admin-iPhone
Aug 17 09:19:07 host kernel: imklog 5.8.10, log source = /proc/kmsg started.

2nd breakdown freeze between 12:01:16 and 12:01:16 :
Aug 17 12:01:16 host dnsmasq-dhcp[2608]: DHCPACK(eth0) 192.168.1.22
1a:c8:b1:8f:8d:6b dell-PC
Aug 17 12:06:36 host kernel: imklog 5.8.10, log source = /proc/kmsg started.

3rd breakdown freeze between 13:40:42 and 13:49:19 :
Aug 17 13:40:42 host dnsmasq-dhcp[2606]: DHCPACK(eth0) 192.168.1.247
4c:4f:c8:9a:aa:ea apples-MBP
Aug 17 13:49:19 host kernel: imklog 5.8.10, log source = /proc/kmsg started.

You said that the NS is not goes to shut down, only freezed.
Could be from ACPI.
Please try this: http://www.putorius.net/2014/12/diables-acpi-on-red-hat-centos.html

I cannot give you more informations about ACPI on Linux. I’m not a Linux expert.

Looking at the log excerpts you posted, it may be related to a lot of components, but mostly an hardware problem.
The first candidate is the power supply, then the motherboard. Try to keep a monitor attached to the vga port and look for messages on the screen when the system crashes.

1 Like

Thanks,

I will try it and check what happen.

I will try it and check what happen.

But until now can’t try to keep an monitor attached to the VGA port and
look for messages on the screen when the system crashes because it’s goes
blank and freeze.

Thanks.

I concur here with @filippo_carletti, I experienced the same hanging and freezing on users, only my server was a dell Machine. We copied the config , bearing in mind this was on nethserver 6. And went onto a blade server everything went away, we left the problem machine in a controlled and monitored enviroment for 2 weeks. (I know long time, but hey gave me some time to play… :sleeping:.)

It was found the machine’s processsor was overheating. and the hard-drive was experiencing bad sectors.

So maybe a suggestion check your hardware,

1 Like

Thanks,

I tried to see what message appears on screen when freeze but nothing, just
the screen freeze and if I’m writing a command it’s just freeze and can’t
complete the command.

1 Like

Maybe you’re experiencing a similar case as @clinton had. Check the hard disk for bad sectors.

1 Like

Did you get this problem fixed ?

We had similar issues with a machine where it was ‘freezing’. First sign was a general slowing down of the performance - we thought it was workload related - but it turned out to be the HDD failing. This was over a couple of weeks, it was not immediate.

I agree with [quote=“dnutan, post:14, topic:4139, full:true”]
Maybe you’re experiencing a similar case as @clinton had. Check the hard disk for bad sectors.
[/quote]

Check the HDD with SMARTD and if there is anything with errors, change the HDD as it will only get worse over time.

We decided to replace our Nethserver hdd with a SSD, and the performance is much better (and quieter).

2 Likes

It seems that the HW caused the problem, until now since 5 days every thing
is going fine after replaced the HW.

Thanks a lot.

4 Likes