Nethserver as Fileserver. CPU usage 100%

NethServer Version: 7.9.2009
Module: Samba

Dear at all,

i am using Nethserver as Fileserver in an Zentyal domain.
Nethserver itself is installed on KVM VM.
All is running well. At one time the CPU usage runs to 100%.
I have no explanation what cause the trouble.
attached some screenshots.
Could

HTOP:

VM Info out of Proxmox

Samba service

After increasing to 8core from 4core

I dont believe that nethserver would need this hardware requirements for an samba server or?
So i think this is maybe caused for an wrong setting?

Many thanks for your help.

best regards

Thomas

Which model is the phisical CPU? And chipset?

its on an dual sockel system
2x AMD EPYC ROME 7302
Motherboard
Gigabyte Mz72HB0

1 Like

Thanks for the information, certainly should not waste so much CPU time on smb daemon.
@support_team any experience on this kind of CPU?
Rome generation of Epyc should be fully supported by CentOS, as well as proxmox.

Are you using 10GbEth also for samba? Which driver is ProxMox using?

1 Like

Yes i have on host created an Bridge on 10GB Nic.

For CPU i use the recommended KVM CPU emulation.

But the same issue i had also on vbox virtualisation.
I have used before vbox as hypervisor a long time.
The same behavior. At this time i thought the problem is vbox. Than i created a complete new 3 Node hyperconverged-cluster based on proxmox+ceph+kvm.
Before it was an 2 Node cluster ubunut+drbd+vbox and complete different hardware.
But as i write here was exactly the same behavior. Only an restart of the system solve the problem.
But it occurs anytime again.
Without any visible reason for me the cpu usage jumps up and the complete network throughput goes down.

It is an 4-Port 10gb NIc X710Chip
But my network i/o looks good as the same as the read/write on storage.

lspci | grep Ethernet
21:00.0 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 02)

dmesg | grep i40e
[ 7.352110] i40e: Intel® Ethernet Connection XL710 Network Driver - version 2.8.20-k

Hi at all,

my problem is not solved and it occurs again.
I see that in the log are errors that has something to do with services that i can see on htop that bring 100% CPU usage.
Maybe someone has an idea with this new informations

many thanks for help

regards

@filippo_carletti? @federico.ballarini? @giacomo? (alphabetically sorted…)
Any idea/experience/hint?

Hello

I am usig a XCP-NG 8.2 and a Nethserver 7.9. too with AD. XCP-NG ha also problems with 10G. Is the internal Networkconnect using 10G to ?

Some combinattion between Host VM and Hadwar can have tis kind of problems.

What did the Proxmox and KVM experst thinking ?

I would suggest to configure qemu-guest-agent under Proxmox:

And install it under Nethserver CLI:

Next step is to shutdown the Nethserver, a reboot is not enough.
Boot Nethserver again and watch the RAM/CPU…

What Type of CPU do you use? You can use Host for better hardwaresupport…

i had this problem also on vbox on an system where is no 10gb nic shared.
You know how this must be setup in the guest?
I thought it is by default that the VirtIO driver see by itself that 10gb it is possible.

I think yes but not sure

allready installed and configured like described in pve wiki

here i have an difference
My Setup is as default
kvm64

i will try it with host and will see if i get the trouble again

as Network i use VirtIO (oaravirtualized)
I dont know exactly if there the 10gb will run per default.
I have made no iperf test.
Would you say VIrtIO is good or should i change?

@LoTex

Hi

I have about 30 clients with NethServer running as AD on Proxmox. All are running with KVM64 and VirtIO Network and Disk.
The largest Nethserver has 60+ users, is about 800 GB big and is the main fileserver. This client has 3 sites connected with VPNs, and all sites use this single NethServer on Proxmox…

All working well!

My 2 cents
Andy

WE had a lot of problems with XCP-NG with 10G Ethernet on the XCP-NG side. Reason was the cytrix bug support do not support Xenserver real good. So the french guys try to fix it.

Mostly 10G ha a low bandswitch like 1500 MByte/s. Sometime was faste but than the CPU load was high on the VM and the host.

Same was with boundet Nics

with 10G ?

@Axel

This is a Treuhand company, two Proxmox in Cluster, and PBS activ…

Here are two Win10 boxes running as Server. (MS-SQL…). One has a 10 GBE NIC, the other even has a 100 GBE NIC…

I’ll admit that the first time I saw this I read 100 MBit/S… Tried 4 hours to fix the drivers…
Then I looked again and saw it was running with 100 GBE!!!
Then again, I’ve never seen a server or PC with a 100 GBE NIC!

Note, network performance is very good, but the server only has several 1 GBE NICs connected. (HP Proliants, both. One new, one older.)

Every night, the NethServer has a job which grabs the SQL-Dump from the Windows boxes and saves it on a NAS under a 7 Generation Backup Scheme…

The File on the 100GB Server is about 12 GB big…

My 2 cents
Andy

1 Like