Nethserver Admin UI


(Mark Edworthy) #1

I just tried to access the admin UI on my server and it does not exist.

I have been using the UI on port 980 for the last couple of months but today when trying to access (both from a remote PC and the local server - using elinks), the browser refuse to connect to the service, I have scanned the server using nmap (using command: nmap -T4 -A -v ), I discovered that port 980 does not exist.

So, I thought of manually restarting the service but can’t see any daemons that relate to nethserver in /etc/init.d/

Is there anyway via a console to verify that the UI is running (tried looking for it using htop, only found a reference for smwingsd)

Which RPM contains the admin UI and if I try to reinstall this one rpm, will it effect / change any of my current configuration?


(Filippo Carletti) #2

The Admin UI service is named httpd-admin and is under upstart so the commands are:
status httpd-admin
restart httpd-admin
Also logs are in /var/log/httpd-admin (see error_log).

upstart keeps the service always running, so you may be right thinking that it has been removed (don’t ask me why, but logs may have hints).

You need to yum install nethserver-httpd-admin


(Mark Edworthy) #3

Ok, checked my logs and can’t find anything strange (except that the last access and error logs where created on created / modified on the 24th – the server is using NTP, so the date is correct)

httpd-admin daemon did not exist (but rpm packaged was installed!)

Removed the package (yum erase nethserver-httpd-admin) and then reinstalled, still no daemon / service.


(Filippo Carletti) #4

Type:
/usr/sbin/httpd-admin -f /etc/httpd/admin-conf/httpd.conf
See /var/log/httpd-admin/error_log


(Mark Edworthy) #5

Found the problem and realised that it was an issue with php. A couple of weeks ago I installed nethserver-php-scl and this was causing httpd.conf to throw out errors, I have removed both php-scl and php56*, and rebooted the server, all is now working.

But weirdly, still no /etc/init.d/httpd-admin or when typing service httpd-admin status, I stll get a ‘unregonized service’ statement (even though the admin UI is now running).

I am now thinking that whilst php-sci is a module in that is still in development, it does need further testing.


(Mark Edworthy) #6

As you might already know, I have been using Webmin as a secondary control panel / UI. According to Webmin, the httpd-admin is a working service that is running via upstart (things where a lot more simpler back in the old days when we where still using sysvinit)


(Stéphane de Labrusse) #7

Fun what it happen…even if you may have errors with nethgui if you use php56 for the whole server…it should not interfer with the httpd-admin service.

I’m interested by errors you found in httpd logs mainly as you noticed it, the module is still in development without feedbacks


(Stéphane de Labrusse) #8

I would be interested also by values concerning nethserver-php-scl

config show httpd
config show php
config show php54
config show php55
config show php56

(Mark Edworthy) #9

The errors I found are PHP based issues (within /etc/httpd/admin-conf/httpd.conf):

Line 169 - php_value session.save_path /var/cache/nethserver-httpd-admin
Line 170 - php_flag magic_quotes_gpc off


(Stéphane de Labrusse) #10

Could you send me the full log please with also the db command

Stephdl at de-labrusse.fr

Did you activate the php56-scl for the whole server ?


(Mark Edworthy) #11

I will reinstall php-scl and php56 later and see if I can replicate the error.


(Mark Edworthy) #12

Ok, just tried to reinstall php56-sci and yes, @stephdl, there is a issue with the admin ui and using php5.6 for the complete server. (I have not tried the other versions of php and am using php 5.3 / default version to run the ui)


(Stéphane de Labrusse) #13

I suppose these are the relevant issues, did you change something in the php56.ini settings…or @davidep @giacomo do you have changed something with an recent update ?

anyway @medworthy thanks for the work you did…I will try to reproduce the error and find a viable solution.

can you test it with other php version please, if you want to return back to the default phpversion you can do it by the command line (default php54 php55 php56)

    config setprop httpd PhpVersion default
    signal-event nethserver-php-save
    restart httpd-admin

(Stéphane de Labrusse) #14

ok confirmed here, it seems that the update concerning the internationalization of nethgui has broken something. I speak of the most recent update but it could be also an older updates

the first idea in mind is that I provide option in /opt/remi/php56/root/etc/php.ini which can bring troubles :slight_smile:


(Stéphane de Labrusse) #15

nope, it is another issues, still looking for


(Stéphane de Labrusse) #16

Okay I found my error, @medworthy thanks for reporting; a new version is coming


(Stéphane de Labrusse) #17
yum install http://mirror.de-labrusse.fr/nethserver/nethserver-php-scl/nethserver-php-scl-1.0.1-2.ns6.x86_64.rpm --enablerepo=remi-phpscl