Nethserver 8 Nextcloud unable to save configuration

NethServer Version: NS8
Module: Nextcloud

Next up in the test is Nextcloud. I am happy to say the app install of Nextcloud finished without issue. But when i tried to save configuration, it produced this error:

I added a FQDN, typed in password, selected User Domain for authentication which is samba on NS8.
I have the complete log of Nextcloud app in a txt file. How do I send it Dev team?

I don’t think you can send it to a team. If there’s no private information in the logs you could use a pastebin site like or etc


Good idea.
Here is the privatebin link for the nextcloud app.

1 Like

From the log it seems the nextcloud-app service doesn’t start (in time) but I’m still in learning stage as regards reading NS8 logs…

Did you enter a FQDN like “nextcloud.domain.tld” that points to your server in DNS? Don’t know if it really matters, just an idea…

Does it contain special chars? If yes please try a simpler password.

Yes i did enter full hostname as FQDN.

I tried both complex and simple password also tried with default neth password as is. Tried it both Samba and local nextcloud authentication option. Same result in all scenario. Nextcloud simply wont finish configuration.

However, i am able to Uninstall the broken instance of nextcloud.


Nextcloud-app got a timeout to start, could you reproduce we normally set a 70seconds timeout

This could be done by slow spinners or slow cpu but we could trick the systemd service to wait for this case

No offense on my side

Could you try to reproduce the issue on your side if yes in the nextcloud-app service i could point you where to add more time.

In fact at the first boot we create the sql database and other services before to start nextcloud-app…it takes a long time for that

1 Like