Nethserver 8 fresh webtop DB error

NethServer Version: NS8
Module: WebTop

This is a clean NS8 test deployment. I installed netdata, imapsync, samba, mail an webtop on it. Created a test user through samba which created an email box. When I logged into WebTop as admin to disable Maintenance Mode, I got a DB error as following:

It did let me disable the maintenance mode. So i logged out and tried to log back in as the test user. But it had Authentication Error and could not login. I double checked the app settings. I created a task oon imapsync to sync the test email box with the real email box on a separate email server. Imapsync seemed to be working fine as I can see emails are loaded on the ns8 email box.
Did i miss a step? What is the DB error mean and why I cannot login to webtop as a user?


Maybe it helps to save the Webtop app settings once more.

I don’t think so as you configured all apps.

Unfortunately “DB error” doesn’t say much so we need the logs please to check what was going on.
When for example the database isn’t available or has errors, user logon isn’t possible because the database is the user backend, LDAP is just used for authentication.

There’s an older post for NS7 about the DB error occuring after updates…

That helps @mrmarkuz ! I repeatedly saved WebTop settings. On the 6th save it worked. I now have a working WebTop. Thank you for the tip.

I also noticed under WebTop > admin > DB Upgrade, when it wasnt working I had handful line item with OK status. At the time it worked I have OK status for almost all the 200+ DB line items.

Shouldnt NS8 save settings properly on the first try? Just mentioning. :slightly_smiling_face:

1 Like

Yes, in any case it should just work.
Saving the app settings starts a configuration task and then maybe the app is restarted and may need some time to work again.

That was my thought as well. So after each save, I gave a good 5-6 minutes before trying the webtop function. I figured 5 minutes should be plenty of time for all pending stuff to finish. On 4th and 5th attempt, I actually gave it over half an hour since I got busy with something else and didnt have time to test webtop. But even after half an hour, webtop still had issue.
So it seems that task just timed out or simply could not finish for some reason?

Yes, that’s possible but we need to check the logs to really know what’s happening.

Which Log would help? The app related or system wide?

I am going to mark this as solved since I was able to make the WebTop DB error go away by saving webtop configuration multiple times. As of now I have a working WebTop connected to Samba for authentication. NS8 is on Debian+BTRFS.

1 Like

The system wide logs are good because sometimes another app is affected, for example traefik. It’s important to get the relevant lines in the time frame the issue occurs.
Sometimes it could be easier to search in the app log because of the filter (in case you have many apps).