Nethserver 7 + sogo3 use of Relay sogo3+activesync+smarthost

sogo
v7
mail

(Stojovski) #1

NethServer Version: 7
Module: your_module

After last update, sogo 3 (ActiveSync) does not use an smarthost, but tryes to send directly and the message comes back with mailer daemon, of course because there is no such a server like neth7.server.local, IMAP with smtp works ok.

How to repair this?

THX


Default sender address
(Alessio Fattorini) #2

Sogo uses the NethServer mailserver, if you have properly configured the smarthost everything should work as expected. Why are you arguing this?


(Stojovski) #3

Hi, i know that sogo works with mailserver , but it strange that when i use ActiveSync with Outlook, mails are send wit local domain name, IMAP + SMTP is fine with real address user@domain.com.I didn’t change anything, it worked before an update.That’s why am asking here.


(Stojovski) #4

I think that masquerading does not work ActiveSync, but worked before. hmm, if i find some solution i will write it here


(Stojovski) #5

It does not work.It Works only with imap/pop3 and smtp.
I can’t send any mail with Activesync, it does not rewrite Adress from domain.local to domain.com.
It must be some bug, it worked before without any problem, and i have another Nethserver 6.9 , it works.Only Neth 7 does not work.
Poor, that after some updates , like MS we must afraid if something works or not.


(Michael Kicks) #6

NethServer 7, as far as i can see, has quite different genesys from Nethserver 6.8/6.9. Thanks to sssd can be used in ways that NethServer 6.8 cannot achieve.

Therefore, something works differently. And maybe the rewrite is working only on few services.
@dev_team maybe can reproduce the issue and find the way to solve your needs…


(Stojovski) #7

THX, that would be great if this can be solved.
Only to know:
Its with samba active directory auth. not LDAP
Example:
samba is working great,.
hostname is; neth7.domain.local
I made accounts , and in SOGO changed the Mail adress to mail@domain.com and Reply-To to mail@domain.com.
Smarthost is domain.com with username and password with ssl 587.
When i configure Outlook with IMAP/SMTP i can send mails, but with Activesync comes "Sender address rejected: not owned by user ", and i see that sender mail maps to domain.local, not domain.com.
But it worked before last update.

THX


(Michael Kicks) #8

Could you please provide a printscreen with the outlook configuration?


(Stojovski) #9

Yes<im


(Stojovski) #10

Everything else works, Adress, Calender<

PLEASE DELETR it after, both pictures

THX


(Stojovski) #11

I already called Provider, but he can do anything , smtp works.They checked everything


(Uwe) #12

Moin Stojovski,

what Outlook client do you use?. With Outlook 2016 you must use autodiscover.

Regards

Uwe


(Stojovski) #13

ITS local Server No need autodiscover and ITS out2016 and worked win not in ad


(Stojovski) #14

I have tested again, the problem is in dns + SOGO.

Found this also, and i think that this is the problem:

"Feb 31
Sorry, I thought that is a new installation and you have problems with receiving emails. I didn’t read too careful.
If activesync takes the internal domain, is correct to have invalid mx record.
The MX record must point to the FQDN.
Maybe is something wrong with the DNS, network configuration, firewall, …, after the update.
Maybe is not related directly to SOGo.

PS:

The updates were for SOGo?"

Directly from SOgo works ok, SMTP/IMAP account in Outlook works OK, only activesync problems, but only on send, receive works fine.


(Stojovski) #15

Anyone with some solution?


(Stojovski) #16

I have looked live logs maillog, whenn i send thru IMAP/SMTP account it takes corectly the smarthost, but when i send thru Activesync takes localhost .
Where to change this, or maybe custom-template?

THX


(Stojovski) #17

I found some solution on community sites at Nethserver, but this is not really the best.With generic maps, but why does Nethserver does not do that.I can now send also with Activesync Account form Outlook 2016.
I have to write all addresses manually, :tired_face:

I thought this can be done with E-Mail Aliases, but not for Activesync and Sogo.
Maybe this can be fixed?

THX


(Stojovski) #18

Changed to Webtop 5. Works TOP.
Sogo is not working in version 3.2.10.


(Stojovski) #19

Any news on this issue with SOGO and Outlook 2016??

Workout until now with generic:
put an custom-template 70_generic with:
smtp_generic_maps = hash:/etc/postfix/generic

and then put in generic file:
user@domain.local user@domain.tld

than
postmap generic in /etc/postfix
than
signal-event nethserver-mail-server-update

and it works, but this is not a solution, only workaround.
Imagine you have a 200 accounts :scream::scream: