Nethserver 7 arm update

testing
rpi
arm

#1

i’ve found some time for ns7arm
before release the new package i would like to have opinions by all interested…

  1. i’m evaluating to differentiate the config of the epel repo by arch. while there is no an official epel repo for arm32, there is for arm64. So if the install is done on a rpi, the epel on my mirror will be used, otherwise if install is on arm64 the official epel repo will be used

  2. testing the updates require lot of time… :frowning: so i’ve added a new repo: nethserver-crt
    it is simply a copy of nethserver-updates for x86_64. So if you want test the latest updates from NS7 you can enable it and update a single packages or all (which are still a subset of what is available for x86_64), report back so i can move in nethserver-update

  3. some minor fix on install script to work also on pine64

  4. some minor fix on install script to work also on Scaleway VPS arm64 (network.service was masked), still to test on bare metal

i’ve some problem in upgrade package:
for both arch: due to an incorrect naming in previous package, to update the only way for now is to remove olda package and reinstall the new one
for aarch64: simply installing new package will not enable the official epel, so additional steps are:
delete epel.repo and reinstall epel-release

i’ll document those steps in the wiki if we continue on this path

this is the new install package to test:
http://mirror.framassa.org/nethserver7-arm/nethserver-release-7-3arm.6.gb390d5e.ns7.noarch.rpm

tnx


:flag_de: Deutscher Chat
:flag_de: Deutscher Chat
(Giacomo Sanchietti) #2

Kudos! :clap:


(Alessio Fattorini) #3

That’s a great news! @arm_team would you like to help this guy?


#4

some small status update:

  • added nethserver-diagtools to basic install group
  • retested install on rpi3, pine64, scaleway vps armv8: seems ok
  • updated basic install using nethserver-crt repo: seems ok

screenshot of scaleway vps 16 ARM 64bit cores:

:


(Markus Neuberger) #5

First testing on raspi3 succeded.
nethserver-crt repo working, I installed with the package and updated with nethserver-crt.

Installed as described in the Wiki: https://wiki.nethserver.org/doku.php?id=ns7_rasp&s[]=pi
Using the new install package:

Install WLAN, found a script: https://www.raspberrypi.org/forums/viewtopic.php?f=56&t=146109
curl https://gist.githubusercontent.com/anonymous/9119317cdf0c141cb50c523db0f3b70f/raw/d4c2bedcf4799783ca0bf5f54a52e82241faea93/wifi-setup-c7-rpi3.sh >> wifi-setup.sh
chmod +x wifi-setup.sh
/wifi-setup.sh

Setting up bridge br0, but can’t use wlan0, anybody played with WLAN on raspi3 already?
EDIT:
Managed to setup wlan0 as green with:
db networks set wlan0 ethernet role green ipaddr 192.168.1.13 netmask 255.255.255.0 network 192.168.1.0 onboot yes bootproto static
Now I can access both adapters(eth0,wlan0) from lan. :sunglasses:


(Markus Neuberger) #6

Another rpi3 status update:
Installed Packages:
nethserver-base.noarch 3.0.34-1.ns7 @nethserver-crt nethserver-collectd.noarch 3.0.6-1.ns7 @nethserver-crt nethserver-devtools.noarch 1.2.0-1.ns7 @nethserver-base nethserver-diagtools.noarch 1.0.0-1.ns7 @nethserver-updates nethserver-directory.noarch 3.2.3-1.ns7 @nethserver-crt nethserver-dnsmasq.noarch 1.6.5-1.ns7 @nethserver-crt nethserver-firewall-base.noarch 3.2.4-1.ns7 @nethserver-crt nethserver-firewall-base-ui.noarch 3.2.4-1.ns7 @nethserver-crt nethserver-hosts.noarch 1.2.1-1.ns7 @nethserver-base nethserver-httpd.noarch 3.1.4-1.ns7 @nethserver-crt nethserver-httpd-admin.noarch 2.0.11-1.ns7 @nethserver-crt nethserver-ibays.noarch 3.1.1-1.ns7 @nethserver-crt nethserver-lang-de.noarch 1.2.1-1.ns7 @nethserver-crt nethserver-lang-en.noarch 1.2.1-1.ns7 @nethserver-crt nethserver-lib.noarch 2.2.5-1.ns7 @nethserver-crt nethserver-lsm.noarch 1.2.3-1.ns7 @nethserver-crt nethserver-mail-smarthost.noarch 0.1.1-1.ns7 @nethserver-updates nethserver-mysql.noarch 1.1.1-1.ns7 @nethserver-base nethserver-nextcloud.noarch 1.0.2-1.ns7 @nethserver-base nethserver-ntp.noarch 1.1.3-1.ns7 @nethserver-updates nethserver-openssh.noarch 1.2.1-1.ns7 @nethserver-updates nethserver-openvpn.noarch 1.4.8-1.ns7 @nethserver-updates nethserver-phonehome.noarch 1.2.1-1.ns7 @nethserver-base nethserver-php.noarch 1.2.0-1.ns7 @nethserver-base nethserver-release.noarch 7-3arm.6.gb390d5e.ns7 installed nethserver-samba.noarch 2.0.8-1.ns7 @nethserver-crt nethserver-smartd.noarch 1.1.0-1.ns7 @nethserver-base nethserver-sssd.noarch 1.3.0-1.ns7 @nethserver-crt nethserver-virtualhosts.noarch 1.0.5-1.ns7 @nethserver-crt nethserver-vsftpd.noarch 1.1.0-1.ns7 @nethserver-base nethserver-yum.noarch 1.4.1-1.ns7 @nethserver-base

Packages installing without problems! German language is working too…

With my /boot/config.txt I get 1200 MHz at about 60 C° CPU temp, original config.txt from centos was at 600 MHz:
arm_freq=1200 hdmi_force_hotplug=1 config_hdmi_boost=4 overscan_left=24 overscan_right=24 overscan_top=16 overscan_bottom=16 disable_overscan=0 core_freq=400 sdram_freq=450 over_voltage=0 force_turbo=1

Check CPU temp:
[root@centos-rpi3 ~]# cat /sys/class/thermal/thermal_zone0/temp 57458
Check CPU speed:
[root@centos-rpi3 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 1200000
Divide through 1000, so I got 1200 MHz@57,5°C.


(Alessio Fattorini) #7

Are you here too? :slight_smile: keep it up man.


(Markus Neuberger) #8

Here, there, everywhere. :wink: There’s so much to discover, translate, test etc.

For sure!


(André Wismer) #9

Hi All!

Great, another new thing to test on my Raspberry park…

I’ve got a NetBerry running (I’m impressed how fast that runs on 1 GB RAM!), a FHEM Home control, an OpenHAB home control (For a client in evaluation) a KODI media center and two raspberrys for development. One’s in a PITop Laptop casing in green !
:wink:

Will test this out the next couple of days (Need a new SD for this…)

Cool stuff, guys!
Andy


(fpausp) #10

What is or will be the most powerful ARM-Hardware for Nethserver 7 ?

Is there a businessplan for ARM-Architecture from the Company ?


#11

i suppose the answer probably is that it will be the most powerful ARM-hw supported by centos
you can see here some supported HW
https://wiki.centos.org/SpecialInterestGroup/AltArch/Arm32
or here for more powerful hw:
https://wiki.centos.org/SpecialInterestGroup/AltArch/AArch64

i don’t know…


#12

small update:
installed the aarch64 version of centos 7.4 on odroid c2 with a gigabit eth-usb, crt-repo enabled and installed
openldap
Basic Firewall
Statistics
VPN
Fail2ban
dyndns service

as base-fw seems to work correctly…
i hope to find some time to write some more info on the wiki next week

i’ve also tried to enable nethserver-backup
i can install on aarch64 but i have some major problem on rpi3 due to epel requirements
i think that probably we should split repo and install for armhfp and aarch64. Hope to have an exhange of ideas with @dev_team and anyone interested at the conference to evaluate how to proceed

in the meantime, I did not resist … at the end I ordered this
http://www.hardkernel.com/main/products/prdt_info.php?g_code=G150229074080
I’ll let you know how it goes with ns7


#13

Ho,

Did you think Nethserver on arm is ready for a home setup?
Is this stuff is Nethserver ready?


(André Wismer) #14

@Jim

Hi

Not quite sure I understand this:

Are you taking about NethServer / Arm or about PFSense?
PFSense is a firewall. NethServer is a All-In-One Server.

Not quite the same thing…

Sure, in PFSense you can add in a USB-Disk and have a Instant NAS!
But they never mention anything about redundancy or RAID - for a good reason.

NethServer can handle that!

NethServer / ARM as home setup?
Depends: If you’re OK using it as a fileserver without RAID, maybe.
But RAID on a Raspberry? It works, yes! But I/O… A single Disk works well enough, but for Home / Family use?
100 MB/S isn’t enough for Media streaming in a home environment for 2 -3 users…

In my opinion, OPNsense as a firewall is better than PFSense, but this Forum isn’t the right place to discuss that!

My 2 cents

Andy


#15

Hi,

I’m using Nethserver as Firewall/Gateway only…
And I’m asking if this stuff ( built for pfsense, sure and conscient this :wink:)
Can work with Nethserver/arm…

I actually don’t know if Nethserver on arm architecture is too young or is already well evoluated.
So… I’m asking :wink:


#16

to all NS7-ARM users:
since I have a few hours of free time, I wanted to take some tests on ARM and on the mirror to differentiate the packages available depending on the arm32 or arm64 version.
Please do not update, i will let you knon as soon as i’ve finished


#17

done, i have split the comps xml file so we can have different config for software center on arm32/64
(i still don’t know if it would be better to completely split the arm32 version from the arm64 version…)

changes on software center:
-arm32
updated VPN to openvpn
moved openvpn from extras/testing to firewall

-arm64
updated VPN to openvpn
moved openvpn from extras/testing to firewall
disabled nextcloud (need some tests)
added nethserver-backup (base)
added nethserver-vsftpd
added nethserver-ipsec (firewall)

so a the end this is what we have in software center (for now):

Software Center arm32:
Account provider:

OpenLDAP
Basic firewall
Email
File server
MySQL server
Nextcloud
OpenVPN
Statistics
Web filter
Web server

Software Center arm64:

Account provider: OpenLDAP
Backup
Basic firewall
Email
File server
FTP server
IPsec tunnels
MySQL server
OpenVPN
Statistics
Web filter
Web server

let me know if there are any problems
hope to heve some more time in the next days…


(Alessio Fattorini) #18

@mark_nl is back :smiley:


(Mark Verlinde) #19

I’m setting up develop environments for arm32/64 bit as we speak. :slight_smile:

Kudos to @dz00te for his continuing work on the ns-arm project!


(Markus Neuberger) #20

Updated my Raspberry Pi 3 and it worked as expected! :+1: