NethServer 7.8.2003

I noticed that download speed was very low when you don’t agree accepting cookies. If you accept cookies, downloadspeed is max of your connection.
Ugly… very ugly…

4 Likes

Downloading nethserver iso from torrent is usually fast. No problem here, but any improvement is welcome.

qbittorrent (multi-platform)

Always a good idea to have a good plan.

Yes, of course, I forgot to mention that option. Thanks for reminder.

1 Like

@alefattorini… come on!

1 Like

Pick them as the LockPicking Lawyer do. :wink:
Go public!

2 Likes

Hi,

after updating i have two error messages.

PHP Warning: PHP Startup: Unable to load dynamic library ‘smbclient.so’ (tried: /opt/rh/rh-php72/root/usr/lib64/php/modules/smbclient.so (/usr/lib64/samba/libreplace-samba4.so: version `SAMBA_4.9.1’ not found (required by /lib64/libwbclient.so.0)), /opt/rh/rh-php72/root/usr/lib64/php/modules/smbclient.so.so (/opt/rh/rh-php72/root/usr/lib64/php/modules/smbclient.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library ‘smbclient.so’ (tried: /opt/rh/rh-php73/root/usr/lib64/php/modules/smbclient.so (libwbclient.so.0: cannot open shared object file: No such file or directory), /opt/rh/rh-php73/root/usr/lib64/php/modules/smbclient.so.so (/opt/rh/rh-php73/root/usr/lib64/php/modules/smbclient.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

What must i do to solve the problems?

Thanks in advance…

Uwe

I guess that’s an error in a cron mail.
Please see Release candidate: ISO 7.8.2003

OK,

after a reboot it looks good.

But the Cockpit Login Site shows me the old version 7.7.1908.

I only saw those messages during update 7.7 to 7.8.
I just double-checked the logs and I don’t have any more.

1 Like

After a reboot the system everything works good.

Regards and a sunny weekend…

Uwe

Only Rspamd gives errors in the logging:

 <7nos9t>; cfg; rspamd_language_detector_init: cannot compile stop words for 3 language group: regexp parsing error: 'character value in \x{...} sequence is too large' at position 6; pattern: \x{647}\x{646}\x{627}\x{644}\x{643} 
 <7nos9t>; cfg; rspamd_language_detector_init: cannot compile stop words for 2 language group: regexp parsing error: 'character value in \x{...} sequence is too large' at position 6; pattern: \x{906}\x{92b}\x{942} 
 <7nos9t>; cfg; rspamd_language_detector_init: cannot compile stop words for 1 language group: regexp parsing error: 'character value in \x{...} sequence is too large' at position 6; pattern: \x{441}\x{430}\x{43c} 
 <7nos9t>; cfg; rspamd_language_detector_init: cannot compile stop words for 0 language group: pattern is not enclosed with \: m\x{ed}

@davidep Would having the files hosted in AWS help?

I have an account there and its super simple to drop the files there and those downloading the files would essentially be limited by the speed of their broadband connection.

3 Likes
1 Like

Expanding the link provided by @dnutan,
CPU doesn't have SSSE3 instructions set required for hyperscan, disable it
Quite lucky that my scapegoat’s CPU is old, but not that old. And luckily, also my little oven build (Phenom II 1090T, 125 warms watt of TDP) supports it.

Thank you for the offer! Multiple download locations will be a good plus.
We will reach you when we decide how to rework the whole download process :wink:

Rspamd has not been update, so that warning should be there also for 7.7.

So, about this…

The package that will let you update to NethServer 7.8 has been released.
It will be available from the Software Center as soon as all mirrors are in synch.

If you have rush, use the command from this post.

I was just writing it when I saw your message popping out! :wink:

1 Like
[root@neth ~]# yum update --enablerepo=nethserver-testing nethserver-subscription
Loaded plugins: changelog, fastestmirror, nethserver_events, priorities
Loading mirror speeds from cached hostfile
 * sb-base: u3.nethserver.com
 * sb-centos-sclo-rh: u3.nethserver.com
 * sb-centos-sclo-sclo: u3.nethserver.com
 * sb-epel: u3.nethserver.com
 * sb-extras: u3.nethserver.com
 * sb-nethserver-base: u3.nethserver.com
 * sb-nethserver-updates: u3.nethserver.com
 * sb-updates: u3.nethserver.com
nethserver-testing/7/x86_64/signature                                                                        |  836 B  00:00:00     
nethserver-testing/7/x86_64/signature                                                                        | 2.9 kB  00:00:00 !!! 
nethserver-testing/7/x86_64/primary_db                                                                       | 191 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package nethserver-subscription.noarch 0:3.5.4-1.ns7 will be updated
--> Processing Dependency: nethserver-subscription = 3.5.4-1.ns7 for package: nethserver-subscription-ui-3.5.4-1.ns7.noarch
---> Package nethserver-subscription.noarch 0:3.6.1-1.ns7 will be obsoleting
---> Package sclo-php71-php-pecl-imagick.x86_64 0:3.4.4-1.el7 will be obsoleted
--> Running transaction check
---> Package nethserver-subscription-ui.noarch 0:3.5.4-1.ns7 will be updated
---> Package nethserver-subscription-ui.noarch 0:3.6.1-1.ns7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================
 Package                                   Arch                  Version                    Repository                         Size
====================================================================================================================================
Installing:
 nethserver-subscription                   noarch                3.6.1-1.ns7                nethserver-testing                 51 k
     replacing  sclo-php71-php-pecl-imagick.x86_64 3.4.4-1.el7
Updating for dependencies:
 nethserver-subscription-ui                noarch                3.6.1-1.ns7                nethserver-testing                 26 k

Transaction Summary
====================================================================================================================================
Install  1 Package
Upgrade             ( 1 Dependent package)

Total download size: 77 k
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for nethserver-testing
(1/2): nethserver-subscription-ui-3.6.1-1.ns7.noarch.rpm                                                     |  26 kB  00:00:00     
(2/2): nethserver-subscription-3.6.1-1.ns7.noarch.rpm                                                        |  51 kB  00:00:00     
------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                               140 kB/s |  77 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : nethserver-subscription-3.6.1-1.ns7.noarch                                                                       1/5 
  Updating   : nethserver-subscription-ui-3.6.1-1.ns7.noarch                                                                    2/5 
  Cleanup    : nethserver-subscription-ui-3.5.4-1.ns7.noarch                                                                    3/5 
  Cleanup    : nethserver-subscription-3.5.4-1.ns7.noarch                                                                       4/5 
  Erasing    : sclo-php71-php-pecl-imagick-3.4.4-1.el7.x86_64                                                                   5/5 
  Verifying  : nethserver-subscription-ui-3.6.1-1.ns7.noarch                                                                    1/5 
  Verifying  : nethserver-subscription-3.6.1-1.ns7.noarch                                                                       2/5 
  Verifying  : nethserver-subscription-ui-3.5.4-1.ns7.noarch                                                                    3/5 
  Verifying  : sclo-php71-php-pecl-imagick-3.4.4-1.el7.x86_64                                                                   4/5 
  Verifying  : nethserver-subscription-3.5.4-1.ns7.noarch                                                                       5/5 

Installed:
  nethserver-subscription.noarch 0:3.6.1-1.ns7                                                                                      

Dependency Updated:
  nethserver-subscription-ui.noarch 0:3.6.1-1.ns7                                                                                   

Replaced:
  sclo-php71-php-pecl-imagick.x86_64 0:3.4.4-1.el7                                                                                  

Complete!
[root@neth ~]# signal-event software-repos-upgrade
[root@neth ~]# yum upgrade
Loaded plugins: changelog, fastestmirror, nethserver_events, priorities
Loading mirror speeds from cached hostfile
 * sb-base: u3.nethserver.com
 * sb-centos-sclo-rh: u3.nethserver.com
 * sb-centos-sclo-sclo: u3.nethserver.com
 * sb-epel: u3.nethserver.com
 * sb-extras: u3.nethserver.com
 * sb-nethserver-base: u3.nethserver.com
 * sb-nethserver-updates: u3.nethserver.com
 * sb-updates: u3.nethserver.com
No packages marked for update

I don’t think it’s a matter of “rushing” or being impatient to wonder what’s going on with an update that (it was said) was going to be released a week ago. Especially when the ImageMagick thing is preventing updating anything else.

1 Like

This topic was automatically closed after 6 hours. New replies are no longer allowed.