NethServer 7.6.1810 beta development

@davidep,

Mille grazie!

-HF

1 Like

The firewall packages have been released!

I’m working on the last feature Repository metadata GPG signature

Dependency failed for Network Manager Wait Online

Could you determin the reson of the message?

Let me see if it’s reproducible. Anyway it doesn’t seem an issue…

I agree. It doesn’t seem to be an issue, or at least that it has no effect.
I just was curious.

Thx for reply.

1 Like

Unlocked settings, a lot of packages downloaded. But still 7.5.1804.

yes, unlocked downloads centos 7.6, but retain ns 7.5: it can’t work by now…

To complete the upgrade to 7.6 (almost beta):

   config setprop subscription NsRelease 7.6.1810

Then go to Software Center and run system upgrade.

1 Like

Hi all!

Today I have installed an email server from scratch, starting with NethServer 7.5.1804 final and ending with NethServer 7.6.1810 (beta).
As usual, is a bare-metal server, placed in DMZ.
Everything without any issue, following this steps:

  1. Installed NS 7.5 with nethserver-7.5.1804-x86_64.iso
  2. Upgraded to NethServer 7.6.1810 beta, following @davidep instructions:
    NethServer 7.6.1810 beta development
  3. Installed from Software Center: Email, Fail2ban, POP3 proxy, SMTP proxy, Statistics.
  4. Installed from Software Center: SOGo groupware
  5. Installed LDAP local accounts provider
  6. Setted the email server (SMTP, POP3, …)

Now, I begin to create the users.
From tomorrow, the email server will be in tests.

3 Likes

cc: @davidep

I received this email.
Is quite normal in this situation (beta) or is bad?

Upstream dropped the support for PHP 5.6, but we are still publishing PHP 5.6 RPMS from CentOS 7.5 to provide backward compatibility.
More information will follow inside the release notes.

It happens from time to time. You can safely ignore it.
To fix, clean the yum cache.

2 Likes

It’s not an issue, however until 7.6 final is out (and we switch the stable repository from 7.5 to 7.6) you need to enable the “Locked” policy on 7.6.1810 to get rid of it (hopefully).

1 Like

I did yum clean all and yum update.
I will wait till next cron job to see.
Thank you!

[root@mail ~]# yum clean all
Loaded plugins: changelog, fastestmirror, nethserver_events
Cleaning repos: ce-base ce-extras ce-updates centos-sclo-rh centos-sclo-sclo
              : epel nethforge nethserver-base nethserver-updates
Cleaning up list of fastest mirrors
[root@mail ~]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
epel/x86_64/metalink                                     |  25 kB     00:00
 * ce-base: mirror.yandex.ru
 * ce-extras: mirror.yandex.ru
 * ce-updates: mirror.yandex.ru
 * epel: mirror.yandex.ru
ce-base                                                  | 3.6 kB     00:00
ce-extras                                                | 3.4 kB     00:00
ce-updates                                               | 3.4 kB     00:00
centos-sclo-rh                                           | 3.0 kB     00:00
centos-sclo-sclo                                         | 2.9 kB     00:00
epel                                                     | 3.2 kB     00:00
nethforge                                                | 4.0 kB     00:00
nethserver-base                                          | 2.9 kB     00:00
nethserver-updates                                       | 4.1 kB     00:00
(1/14): ce-base/7/x86_64/group_gz                          | 166 kB   00:00
(2/14): centos-sclo-sclo/x86_64/primary_db                 | 242 kB   00:00
(3/14): ce-extras/7/x86_64/primary_db                      | 154 kB   00:00
(4/14): epel/x86_64/group_gz                               |  88 kB   00:00
(5/14): ce-updates/7/x86_64/primary_db                     | 1.3 MB   00:01
(6/14): nethforge/7/x86_64/group_gz                        | 1.1 kB   00:00
(7/14): nethforge/7/x86_64/primary_db                      |  17 kB   00:00
(8/14): nethserver-base/7/x86_64/primary_db                | 292 kB   00:00
(9/14): nethserver-updates/7/x86_64/group_gz               |  20 kB   00:00
(10/14): epel/x86_64/primary                               | 3.6 MB   00:02
(11/14): epel/x86_64/updateinfo                            | 935 kB   00:02
(12/14): nethserver-updates/7/x86_64/primary_db            |  94 kB   00:00
(13/14): centos-sclo-rh/x86_64/primary_db                  | 3.6 MB   00:04
(14/14): ce-base/7/x86_64/primary_db                       | 6.0 MB   00:05
epel                                                                12738/12738
No packages marked for update
[root@mail ~]#
1 Like

Thank you Davide!
I already did it.

1 Like

Hi all!
cc: @stephdl ; @giacomo

Just installed the following updates.
Where I should find nethserver-mail-quarantine settings?
Is this module available for NS 7.6.1810 beta? (Ref: Rspamd quarantine feature )

TIA,
Gabriel

Dec 07 18:56:08 Updated: nethserver-base-3.6.1-1.ns7.noarch
Dec 07 18:56:09 Updated: nethserver-mail-common-2.4.1-1.ns7.noarch
Dec 07 18:56:09 Updated: nethserver-mail-filter-2.4.1-1.ns7.noarch
Dec 07 18:56:10 Updated: nethserver-sssd-1.4.6-1.ns7.noarch
Dec 07 18:56:10 Updated: nethserver-subscription-3.2.1-1.ns7.noarch
Dec 07 18:56:11 Updated: nethserver-release-7-10.ns7.noarch
Dec 07 18:56:11 Updated: nethserver-nethforge-release-7-3.ns7.noarch
Dec 07 18:56:12 Updated: nethserver-subscription-ui-3.2.1-1.ns7.noarch
Dec 07 18:56:13 Updated: nethserver-mail-server-2.4.1-1.ns7.noarch
Dec 07 18:56:13 Updated: nethserver-directory-3.3.2-1.ns7.noarch
Dec 07 18:56:13 Updated: nethserver-mail-p3scan-2.4.1-1.ns7.noarch
Dec 07 18:56:14 Updated: nethserver-mail-quarantine-2.4.1-1.ns7.noarch
Dec 07 18:56:14 Updated: nethserver-mail-disclaimer-2.4.1-1.ns7.noarch
Dec 07 18:56:15 Updated: nethserver-mail-smarthost-2.4.1-1.ns7.noarch
Dec 07 18:56:39 Updated: nethserver-fail2ban-1.1.2-1.ns7.noarch

1 Like

in the documentation, http://docs.nethserver.org/en/v7/mail.html#quarantine-beta

actually just command line option

1 Like

Thank you Stephane!
Now, I will wait for the first email notification!

Kind regards,
Gabriel

You will see it will be really interesting :slight_smile:

Ooo! I know that! I already use it with NS 7.5!

1 Like

Hello!
Just for info, same message.

Gabriel

Hello!
It works as we expected!

Gabriel

1 Like