Netflix 139:NFerr_MC_NoCDN error on IOS devices


#1

With the Web Content Filter enabled, IOS devices like iPhone and iPad can no longer access Netflix. The Netflix app opens up and can browse the movies/shows selections without issues. But when trying to play a video, this error comes up “139:NFerr_MC_NoCDN”.

With the Web Content Filter disabled, the videos load just fine.

I would like to keep Web Content Filter enabled while being able to stream from Netflix. Can anyone provide any help in this regard? I am NethServer 6.7 with the latest updates.

Thanks


(Filippo Carletti) #2

If the web filter is blocking access to netflix, you should find something in the relevant log: urlfilter.log.
From there, you should be able to whitelist netflix.
If you need help, please show the content of urlfilter.log at the time you see the error in netflix.


#3

Also note that a lot of Netlix’s cdn are ip instead of url.


(Filippo Carletti) #4

Good hint. By default, access to ip addresses is blocked to fight malware.
The first step could be to enable Block access to web sites using ip address in the default filter.
If you’d like to protect other devices, you could create two profiles and assign the one with ip enabled to the apple devices.


#5

Thank you for the feedback. I think setting different profiles with IP address is a great idea. I will take a look later and post an update.