Netdata webinterface access

I come from realizing that nethserver netdata access does not work anymore for our nethservers.

Trying to access i get
Access to file is not permitted: /usr/share/netdata/web//index.html

How can this be fixed? Although it was working some time ago, I tried to To enable the access from LAN, executing the following once again:
config setprop netdata Bind access green
signal-event nethserver-netdata-update
signal-event firewall-adjust
But that did not help.

I can reproduce.
Please, try changing line 22 of /etc/netdata/netdata.conf to:

    web files group = netdata

Then restart the service (systemctl restart netdata) and let us know if it fixes the problem.

I’m still investigating the source of the problem (upstream), it seems it happened to many:


Thanks. The change you suggested fixed it.

Thanks for the feedback. A fix is on the way. Issue:


Let’s see what I’ve played now …
He does not let me access

[root@server ~]# rpm -q nethserver-netdata


[root@server ~]# curl localhost:19999 | more
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    97  100    97    0     0  42731      0 --:--:-- --:--:-- --:--:-- 48500
Access to file is not permitted: /usr/share/netdata/web&#x2F

I followed

and on line 22 it already appears

web files owner = root
web files group = netdata

But I still can’t access

1 Like

Same problem here.
Did you solve it?

It worked.

I uninstalled nethserver-netdata from Software Center and I removed the modules
yum remove -y netdata-1.29.3-1.el7.x86_64 netdata-data-1.29.3-1.el7.noarch netdata-conf-1.29.3-1.el7.noarch
So I installed it again
yum install -y netdata-1.29.3-1.el7.x86_64 netdata-data-1.29.3-1.el7.noarch netdata-conf-1.29.3-1.el7.noarch
And from Software Center nethserver-netdata

Did you do this?
After that it worked on my side.

1 Like