Need Help email. Sending email outside

NethServer Version: 6.8
Module: your_module

Hi, I have problem in my nethserver and i can’y figure out how to solve this. I setup email in my nethserver 6 and it’s working fine except when i email outside. But when it comes in receiving email i have no problem. can you check the logs i attached when i tried to email outside. Im sorry guys im very new in linux. Thanks and God Bless.

Maybe your ISP doesn’t permit connections on port 25 to the other servers?

Try enabling and configure the smarthost with the SMTP configuration of your ISP.

1 Like

Thanks, But how can i do that? Im using pfsense as my firewall but i dont know how to enable and configure smarthost with the SMTP. Thank you so much…

Every connection fails with a timeout? Looks like you’re filtering/blocking outside connections with pfsense

Take a look at this:

Ok, check if your pfsense blocks port 25 from your lan to the internet.

If pfsense blocks it, open the port on pfsense (if you can, permit to use port 25 to the internet only for the ip addess of the Nethserver).

You find the smarthost in Nethservice:

Email -> tab “Messages” -> Activate “Send using a smarthost” -> Compile the fields that appearing.

1 Like

Hi alefattorini,

I think my configuration in pfsense was correct because when i tried to send an email in my existing email server its working except to the others like google,yahoo etc. Thanks bro!

Hi Saitobenkei,

what username and password should i use in smarhost? Is my nethserver username? thanks

Where is your existing email server? In the same lan where is the Nethserver or on internet?

With your existing email server you can sent to google, yahoo, etc?

In the smarthost you have to insert the credentials of SMTP connection usually provided by your Internet Provider.

Maybe you have to put only the SMTP server of your internet provider without username/password.

Try checking “allow unencrypted connections” under Port (always in smarthost).

1 Like

Hi saitobenkei, I had put SMTP Server of my internet provider without username and password with allow unencrypted connection but still the same. Regarding my existing mail server it is different network i just wondering why only in my existing server work my sending outside? The reason why I build nethserver is to change my existing mail server. but my problem is sending outside? Is it possible the Internet Provider is my problem or I have to call to them and I will tell my issued about sending outside to open the port of my public IP? I’m sorry guys I am new IT, I hope you will help me. Thank you and God bless. :slight_smile:

Ok, your working server is outside your lan so it doesn’t affected by pfsense.


We need more informations about your configuration to help you:

Where is your working mail server. Cloud, at ISP?

How to manage the mails your users now? Via webmail or with some program like Outlook or Thunderbird?

If you can, write here the SMTP configuration provided by your ISP (server name, port and encryptrion) and/or a link to the page where your ISP explains how to configure SMTP.


Put here the log /var/log/maillog when you try to send mail through your ISP.

Check your pfsense if it allows the connections from lan to the internet for the port 25.

Hi saitobenkei, Im Sorry for my late respond I was busy for past few weeks but my problems still the same i dont know what should i do I asked my ISP and according to them there’s no problem to them.I asked also to have my SMTP configuration provided to my ISP but they did not provided SMTP. They give only the details of my static ip. Is it possible to create own SMTP to work my email? as per them, I dont need to use SMTP as long my configuration is working properly. what do you think?

What do you use to read and send mails with the actual server?
Webmail or a client like Outlook or Thunderbird?

If you use Outlook or Thunderbird check their smtp configurastion and, if it doesn’t point to the actual mail server, put it in the smarthost of Nethserver.(check for user and password too!).

Another thing to try to check if the connection works:
Open a shell in your Nethserver and digit:

telnet 25

You should have a answer similar to:

Connected to
Escape character is '^]'.
220 ESMTP a129si1660374wma.19 - gsmtp

If you have a different answer, post it here.

If you don’t have any answer I think that port 25 is closed somewhere (pfsense, ISP, …)


Im using both webmail and outlook but the problem is the same. I couldn’t send email but i can received email to others. I double check my pfsense and im pretty sure I open the port 25.

I’m a bit confused…

What is the LAN Ip of Nethserver? ( is your actual mail server?

if the IP of the Nethserver is 172.16.x.x it seems that is in the same lan and not outside…

Please you try telnet command to the google server (as command in my previous post?)

I don’t know pfsense but, reding your screenshot, it seems that you have opened port 25 from WAN (Internet) to (LAN).
You have to check if you have the port 25 opened from LAN to WAN.

Someone has some other ideas?

1 Like