Moved from VMWare ESXI 6 host to 7, can not find domain

NethServer Version: 7.7.1908
Module: nsdc

It has been working fine for a year. We are in the process of upgrading our equipment and so moved the Neth to a ESXI 7 host and now it is not. I understand about setting the vswitch to promiscuous mode and the why, which is curious as the old one is set without promiscuous but with the other two options on.

I can ping the Neth nsdc ip and it’s fully qualified name and can connect to port 53 but nslookup gives nothing. Samba shows file shares and the default Windows workgroup and my local domain but when trying to connect via Windows 10 I’m getting no domain found. The service is running. I checked a bunch of posts that came back to promiscuous mode which I’ve had on.

I fired it back up on the previous ESXI 6 host and it runs fine. I’m stumped.

Any tips are appreciated !

“No promiscuous mode enabled” => NSDC cannot be reached.
ESXi 7.0.2 and going on direct experience about that. If in ESXi 6.0 worked… a bug?

Thanks for the quick response. I had it enabled with no difference. The ESXi 6 host has allow forged transmits and MAC changes checked but no promiscuous. I’ve been dreading rebooting the host with all the crap running on it and don’t like just shotgunning things without understanding what’s going on but crap’ola I guess. I am making a little server with different addresses to try and see what is going on.

I spun up a Neth 7.7 with nsdc on the ESXi 7 and it worked fine. Will retry the move later today.

AFAIK promiscuos is “receipt” after the boot… If I’m enabling promiscuos, running hosts wont’ be working until a reboot.

I currently don’t remember exactly if the Ip address for NethServer is on the virtual interface or on the bridge; should be the first one. NSDC must have IP address on virtual interface.
Also: I don’t know if the mac address is the same (IP should be) but some switches don’t like that much two the same IP on two mac addresses.
Might also happen that the mactable of the working computer associate the NSDC/ESXi 6.0 mac address for the container IP.

Hi @psionprime1

And welcome to the NethServer Community!

As an very longtime VMWare user (Pre 2000!), I’ve moved about 5 years ago to Proxmox.
I still have one client running Novell Netware, and as these “dead” systems do not run on Proxmox (No driver support), but they do run well in VMWare.

As this client wants to keep the Novell Netware running - for legal reasons as a financial services company, they need to keep records 10 years by law. And I did not want to have an extra server running just with VMWare for running Novell Netware, I began to think about cascaded Hypervisors…

A complete VMWare Server running in Proxmox…
To cut it short, it works extremly well! I now have the advantage of creating incremental Backups of
VMWare ESXi 5.5 using Proxmox and PBS - and this includes the VMDKs of Novell Netware running in VMWare. All with no additional costs!

Anyways: VMWare ESXi 5.5 already had the option for promiscious, I just checked.
As ESXi 7 still has promiscious, I assume ESXi 6 also has promiscios - I just don’t have one running to check…
You can find it under Configuration → Network → Settings → VM-Network → Security…

Screenshots (Sorry, only in german!):

Here are the settings:

And here is what VMWare “sees” of the Proxmox virtualized hardware…

BTW: It’s quite easy to export the VMDK from VMWAre ESXi to Proxmox, the convert the file from VMDK to Proxmox raw or qcow2. You can actually retain both NICs and MAC address - and NethServer runs great under Proxmox.

You can also run your VMWare ESXi 7 under Proxmox!

Hint, hint!

But before anything, make sure you have a full backup of NethServer (Using Nethserver, and VMWare, copy the VMDK and other settings!) and finally UPGRADE your NethServer to 7.9 !!!
7.7 is already quite old, a grandfather by now!

My 2 cents

Thanks guys. It magically started working. I am super not happy with that but need to let it go for now. Thanks for the Promox tip. I’ll look into it, that and Beehive as one of my backups systems is TrueNAS.

MAC table expired?