Mock fails on the ns6 architecture


(Stéphane de Labrusse) #1

Hi @dev_team

I recently cannot build on the ns6 architecture on my Fedora25…the mock fail message is

# /usr/bin/systemd-nspawn -q -M 1f1f7e68932e432e9e7698139b89c6cc -D /var/lib/mock/nethserver-6-x86_64/root -a --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=HOSTNAME=mock --setenv=SHELL=/bin/bash --setenv=LANG=fr_FR.UTF-8 --setenv=PS1=<mock-chroot> \s-\v\$ --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=HOME=/builddir --setenv=TERM=vt100 -u mockbuild /bin/rpm -Uvh --nodeps /builddir/build/originals/nethserver-php-scl-1.0.6-2.fc25.src.rpm

I have another VM with centos7 and of course I have no problems to build for ns6…what is fun is that I changed nothing recently. I tried to remove the cache but with no success (/var/cache/mock/)

An idea ?

mock ns6 configuration


(Davide Principi) #2

Recent releases of mock support systemd-nspawn builder. I suppose it is the new default on Fedora. You could try to switch back to “chroot” mode in /etc/mock/site-defaults.cfg.


(Stéphane de Labrusse) #3

thank for the hint

https://www.systutorials.com/docs/linux/man/1-mock/

--old-chroot
    use old chroot instead of systemd-nspawn. 

add this option to your mock build script

As the doc states

--new-chroot
    use new chroot (systemd-nspawn) - this is experimental and will break existing scripts.

Now it works