Meshcentral picks wrong hostname for agents

After Installing Meshcentral on my server, i noticed that the hostname it uses for the agents is of a different sub domain that the hostname that has been designed for it.

both are hostnames on the nethsevrer instance, while one is used with Joplin notes Server.

i have
mesh.domain.tld which has been defined to be used by the meshcentral isntance.
notes.domain.tld whihc is defined for joplin server.

wen i get the agents for download, the url being used is that for the notes.domain.tld, why could this be happening and how can it be resolved?


Most likely just simple DNS issues…

I have 3 Mesh Servers, all on NethServer with plenty of Domains on the same server (around 10 fqdns…). The downloaded file contains the correct URL, as can be seen here:

My 2 cents

know how i can trouble shoot to fix the issue?

Check the notes.domain.tld, I assume that one is pervailing…
Try removing that virtual host, reboot or restart all apache stuff, and check again…

You can still add in the virtual host later on, if you found out it’s that one causing problems.

Note: In my case (you ought to know :slight_smile: ), the domains (actually fqdns) are not the real host-fqdn in my case. My host’s fqdn is actually, and that is not used by MeshCentral at all…

My 2 cents

Did you try to reset the virtualhost…

config setprop meshcentral VirtualHost mesh.domain.tld

…and applied the config?

signal-event nethserver-meshcentral-update

To output the domain used by meshcentral:

grep Cert /opt/meshcentral/meshcentral-data/config.json

multiple times tried to reset it.

so i reimstalled the conflicting virtual host, then reset the meshcentral virtualhost, and it worked.

1 Like