Mattermost module

This is a simple Mattermost installation:

  • users are not integrated with system users due to a Mattermost Team edition limitation
  • it’s accessible in HTTPS only
  • you need a dedicated hostname for the virtualhost like
  • no web interface for configuration

Just execute:

yum --enablerepo=nethforge-testing install nethserver-mattermost
config setprop mattermost VirtualHost status enabled
signal-event nethserver-mattermost-update

Then, access ``` and perform the first configuration.

More info here:

Drop your comments below :wink:


troubleshooters needed here :stuck_out_tongue: tests are needed, this is a valuable module


Mentioning here some people interested in the conversation, please help us to test the module :slight_smile:
@robb @Nas @clinton @Jim @jackyes @fasttech @jobezic @stephdl @jaapvdv

No package nethserver-mattermost available.

You remove this package?

did you try @giacomo’s command above?

The package is not in repos

You’re right, I’ve forgot to put it on 7.4.
@davidep can you copy missing packages from nethforge-testing 7.3 to 7.4?

@RiccardoC in the meanwhile, you can install it with this command:

yum install

Done (nethserver-postgresql94 was required as dependency too…)


Thanks Giacomo and Davide

1 Like

I’ve just updated the rpm to latest upstream release (4.4.2).

I didn’t test the upgrade of an existing machine (yet) :slight_smile:

1 Like

Hi, I just tested the latest version, but after a server restart I’m receiving a 503
Looking at the logs it seems to be a firewall issue:
[ERROR] Unable to setup forwarding
[CRIT] Error starting the server, err:accept tcp [::]:8065: use a closed network connection

Any thoughts?


OK, I’m using a certificate, but if I enable the use of TLS is when the server gets broken.
Removing the TLS and leaving “ConnectionSecurity”: “” it works.

So, I’m after getting TLS working.


1 Like

Check if this doc helps:

1 Like

Any chance this module ever integrates with system users (or users from AD join), or will the MM limitation always prevent this?

It’s a limitation of MM itself. If the upstream project opens up the code, we will surely integrate it.

1 Like

I don’t understand.

Should I create the virtual host myself ? If yes, what would be the configuration ? I tried here but the only result I get is Nethserver’s default welcome page.

The module will create a virtual host for mattermost but it will be not visible from the web interface.

Make sure you access the application using the entered virtual host: your machine needs to resolve it.

If you encounter any problem, please post relevant logs.

1 Like

All right, it’s working now. It didn’t at first try, this is why I tried creating the virtual host.

Looks promising !!

1 Like

I’ve got this up and running on my server. It works pretty well at the moment.

It seemed a bit wonky when I first set it up - I had to submit the form for a new account probably a dozen times before it went through, and clicking on links was generally hit or miss. Adding the Mattermost hostname as a server alias under DNS seems to have fixed this issue.

For TLS, I have edited the settings on the Virtual Host to use the correct certificate, and kept the the Mattermost TLS off. I tried using the Mattermost settings, but it doesn’t seem to play well with the Virtual Host.

After looking for a while on other solutions (Zapier, Matrix, Rocket Chat), we think that Mattermost is the easiest and robust Team Chat for NethServer.

The package is ready for QA for anyone!