Mattermost does not send a notification by mail


since today’s update, Mattermost no longer sends notifications by mail. My settings look like this:

SMTP server: localhost
SMTP port: 25
Connection security: None

I have also tried other settings via port 465 and 587, but nothing works. What’s to do?



1 Like

Check clues in maillog, you have probably the answer

Hi stephdl,

There are no error messages in the maillog. When I click on Test Connection in the Admin Console of Mattermost, I get the message: Connection unsuccessful. You do not have the required permissions.



IIRC roundcubemail uses 10587 on localhost for unauthenticated smtp connexion

1 Like

I could reproduce the issue and solve it with

/opt/mattermost/bin/mattermost permissions reset

It seems to be an internal Mattermost error because there’s no error in maillog when sending a test mail from mattermost.
To be on the safe side, a DB backup is recommended.
See also Mattermost docs.

If you use custom schemes and permissions in your Mattermost installation you may have a look at permissions export/import.

Restart the service (don’t know if really needed but just to be sure):

systemctl restart mattermost

It may take some time because of cached data but finally sending mail should work again.

These settings should work.