MariaDB will not start [Crashing]

NethServer release 7.6.1810 (final)

Hi Everyone,
Was wondering if someone could guide me in the direction of understanding why all of a sudden is MySQLd/MariaDB crashing? I only noticed that my Nethserver stopped delivering email to everything a couple of days ago and now I can see that the database crashing (and unable to restart) could be the reason. I figured today I could just update to a newer version of MariaDB and that should fix the problem, but the issue still persists. The new version of MariaDB I installed was
rh-mariadb103-mariadb-server.x86_64 3:10.3.13-4.el7

I don’t know the process for troubleshooting databases, so please forgive me if I sound a bit on the uneducated side. I am willing to learn though. Your input would be greatly appreciated.

PS - I also have the mariadb.log if needed and can attach to hear if that would help. Thanks again.


This seems to come from the software collection, it needs some configuration to start, like the module I do, check the community wiki

Indeed the mysql and message log could help, specifically after you tried to start the service

What about to reconfigure the service (IIRC)

signal-event nethserver-mysql-update

Thanks for the help… What I did was I ended up uninstalling MariaDB altogether and re-installed it. Apparently there was a corrupt data file (something like innodb) that was hosing up mariadb and kept it from properly starting up. I had to restore a snapshot to get back all my data, but now I am back to another issue I thought I had fixed before. That is that SOGo is not displaying properly after logging in. Any ideas why?



SOGo relies on mariadb, without it you cannot use 80% of nethserver applications

That explains a lot then. I think I know what my issues are now. I might have been doing everything with the wrong user. I was logged in as root and reinstalled mariadb and sogo. When I tried to log into mariadb with mysql I was denied access. Then curiously I logged in as serveradminr: su -l serveradmin – and I could log in to mariadb, but none of the tables were there. Could that be the issue??? Using the wrong user to reinstall? The packages are there though.

yum install nethserver-mysql

You probably removed it

Once installed, the mysql user is admin and the password can be find in /root/.my.cnf IIRC

So I guess now since I re-installed sogo and mariadb, I don’t see the sogo database in maria db anymore. How do I get the database re-installed in mariadb/mysql?


Nethserver sogo uses mariadb 5.5.64 installed with nethserver-mysql.

Usually when you reinstall nethserver-sogo it will create the database if it doesn’t exist.

Please check by using

mysql -e 'show databases'

To force reconfiguration which includes creating the sogo database:

signal-event nethserver-sogo-update

1 Like