Mailfilter add header X-spam-Flag

NethServer Version: 7.5 1804 Beta CPU Intel G4400, 8GB Ram, Raid-10-Softraid
Module: Samba, Mail, Mailfilter, Roundcubemail

Hello, I have a problem with the add header x-spam-flag.
No X-Spam-flag header will be added. In RSpamd UI the incoming mail is displayed in orange with “add header”. In the pop-3pconnector “Scan messages with email filter” is marked. Pick up with Pop3 with SSL. In “P3-Scan” Antivirus, Antispam and Pop3s are activated. Also in email mailboxes move into junk. Where is my mistake.

The header I see is just “X-Spam yes”. No “flag”.

Also you mention both methods of accessing POP3 e-mails: POP3 Connector and POP3 Proxy (p3scan). Which of these are you using.


I have activated the spam check in both. But even after disabling one or the other, no spam flag is added to the header.

Are you actually using either. It takes more than just installing the package.

Have you configured the POP3 Connector to retrieve mail from an external server, or configured internal clients connecting to the NS server to use the POP3 Proxy.


1 Like

I got the X-Spam-Flag: Yes but I do not use p3scan or getmail, I’m even not sure that rspamd is well designed to work with :’(

see the documentation, I recall an issue where the lead dev said that this configuration is not really developed

My configuration is: I get the mails from the e-mail provider with getmail. There I activated “scan message with email-filter”. In the Pop3 proxy, the mail and virus filters have also been activated. I thought that then a spam flag is set in the header. Seems not to be right. Is it even possible to write a spam hint to the header if the spam score is above e.g. 6 is.