Mail quotas are not updated

,

Hello,
I also do not update the custom mail quotas on some accounts, I have 5 GB by default and I want 3 accounts with 10 GB, one yes they update a 10 but the other 2 are left with 5 GB.
Can you help me. Thank you.

NethServer Version: NethServer release 7.3.1611
Module: mail

I made a new installation and again had the same problem. I think it’s a bug.
Please help.

Take a look at this post to see if it’s the same problem you are having:

Yes, it’s the same problem, but in the post they do not give a clear solution.

Can you post your installed version of nethserver-mail-server?

rpm -qa nethserver-mail-server

cc/ @asl @davidep

1 Like

nethserver-mail-server-1.10.10-1.ns7.noarch

[root@dc2 ~]# rpm -qa nethserver-mail-server
nethserver-mail-server-1.10.10-1.ns7.noarch

@davidep: not the culprit but isn’t this code missing some (exit) statement?

Sometimes maildirsize is getting the wrong quota (unchanged size) for some users, but don’t know why.

IIRC, there could be also some rounding issue between the selected quota (eg. 300 MB on the slider) and the user’s quota displayed on mail quota page (eg. 306 MB).

1 Like

At line 32, exec() actually executes the command and never returns to bash. See also https://en.wikipedia.org/wiki/Exec_(system_call)

I agree, there can be some rounding issue around :wink:

It’s rather puzzling! I’m currently working on CentOS 6.9 update and NextCloud bugs. Next stop: release the new Accounts provider configuration wizard in testing (almost finished). I’ll be back on this soon, I hope!

got it :blush:

Great roadmap @davidep :slight_smile: are you able to take a look at it @dnutan ? I’m sorry I can’t help you here.

just wanted to add, that the same bug is seen in my enterprise edition also …
and it hurts because I was forced to switch off quota management at all.

Davide, I think there’s a small typo when setting custom quota in /etc/dovecot/quota.passwd as it’s honored only for the last user:

2 Likes

@alefattorini give that man a prize ! :smile:

1 Like

@dnutan’s bugfix is available from nethserver-testing repository! Run the following command to install it

 yum --enablerepo=nethserver-testing update nethserver-mail-server

@mundor, @asl could you give it a try? /cc @quality_team

This is the issue:

@asl could you verify the new packages?

Hello @davidep,

I was testing it now and it seems to work well. I tried to change custom and global quota, switched it on and off and could not find anything wrong on the display and calculation. Thank’s well done - all of you!! :slight_smile:

2 Likes

Please add your notes here and move the bug into verified

Bugfix released in nethserver-updates:

nethserver-mail-server-1.10.11-1.ns7.noarch.rpm