Limit case or little bug?


(Michael Kicks) #1

Hi folks, new strange behaviour.
My test server rely on dynamic IP internet connection, and i am using a Dyn hostname for reach it.
I tried to install Mattermost, i was aware that i needed another hostname for the virtualhost. Therefore, i added another hostname (FDQN) to Dyn, setup the same public ip of the current hostname.
This hostname was also added at Dynamic DNS panel, with login data.
And i told to Mattermost that was it’s virtual host.

Last step was try to receive another Let’sencrypt Certificate. But i got an error…
Failed authorization procedure. mattermost.public.host (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://mattermost.public.host.well-known/acme-challenge/1UI6IhIN2NbjxAAVbQijb1IzIOrVF5W2s6mVAdj6tAw: Error getting validation data

I think that something is going wrong between the hostname and /well-known/acme-challenge/.
There is a dot, not a slash…


(Dan) #2

…and there should be both. It should be /.well-known/acme-challenge/. Looks like a rewrite rule isn’t implemented correctly.


(Markus Neuberger) #3

I can confirm the bug when requesting a LE cert after setting mattermost virtualhost.

The error occurs in web UI only, on command line with /usr/libexec/nethserver/letsencrypt-certs -f it’s working.


(Giacomo Sanchietti) #4

Thank you for reporting!
This is clearly a bug: https://github.com/NethServer/dev/issues/5466

To speedup the QA process, you could try if the fix is working for you:

yum install http://packages.nethserver.org/nethserver/7.4.1708/autobuild/x86_64/Packages/nethserver-mattermost-1.0.0-1.3.pr6.g3579e55.ns7.x86_64.rpm

Please, make sure to not hit also this bug: https://github.com/NethServer/dev/issues/5465
So, if you’re not using the LE notification mail, you should install also that fix:

yum install http://packages.nethserver.org/nethserver/7.4.1708/autobuild/x86_64/Packages/nethserver-base-3.1.4-1.2.pr109.gfb11362.ns7.noarch.rpm

(Michael Kicks) #5

Is the issue confined to MatterMost implementation only? Or also on web interface for certbot?
I will install the new packages into few hours


(Giacomo Sanchietti) #6

The issue is in nethserver-mattermost package, the one on LE it’s a regression that no one has encountered yet (at least, as far as I know).


(Michael Kicks) #7

Therefore, this screenshot is useful for troubleshooting…
immagine
mixed language message.
Maybe the message is not being part of localization, for now.

Packages updated, TeamChat settings re-saved (no change on form, i wanted to expand the template) no error message during certificate request.

And first MatterMost access completed. I have something to play with during April 25th…


(Giacomo Sanchietti) #8

Everything should be already translated, but I will check it.

Could you please tell me what language are you using inside the browser? Does the URL contains it-IT?


(Michael Kicks) #9

Browser is asking italian language and whole Server Manager is correctly translated in Italian.

Mattermost at first login was setup in english, i had to change the language for the user, and also the default language in mattermost was english,


(Giacomo Sanchietti) #10

Mattermost is fully translated, but translation have not been added inside the language pack.
I will do it soon, I will try to group together a couple of fixes.

Edit

You should be able to fix the Italian translation using this command:

yum install http://packages.nethserver.org/nethserver/7.4.1708/autobuild/x86_64/Packages/nethserver-lang-it-1.2.9-1.5.pr19.gbb7bfed.ns7.noarch.rpm

(Michael Kicks) #11

Fix works…
immagine
Only a " is missing before Domini

Also MatterMost, after a restart, was in italian as default language. The localization of admin user had to be changed manually (obviously was the only user that was created with english as default language)


(Giacomo Sanchietti) #12

Thank you, there was a typo in Transifex (https://www.transifex.com/nethserver/nethserver/translate/#it/Mattermost/139058403)