Lightsquid Nethgui: "Language not found"

This error occurred now in Nethserver 7.2 Beta 2, but I first saw it in 7.2 Alpha on a different install. I am now using a Virtual server (ProxMox) with bridge networking, but the Alpha was installed bare metal. Error does not occur in Neth 6.8 which is installed identically as VM on ProxMox. I have fully updated via interface and also via “yum update” to verify, can send package version list if desired.

error occurs when clicking Status / Applications buttons for Bandwidthd and Lightsquid (but not for Ntop)

Also, occurs when selecting Reports / Bandwidth usage

or Reports / Web proxy stats

But selecting the Settings button in either leads to a working page:

A different error occurs upon selecting Reports / Graphs

Should be unrelated, but my servers are on a different sub-net, but I have setup trusted networks and static routes – this should be obvious since the rest of the web interface is working. I even enabled the srcnat masquerade rule I used for initial config of the Nethserver to put myself on the same subnet to rule this out. I’ve compared my config to that of the working 6.8 to double check and cannot find anything significantly different.


Solved: Everything works after rebooting

Including in my previous installation.
Need to reboot the server after installing some packages and updates
(well, one could probably restart all the affected parts, but just restarting the services is not enough)

Was getting ready to post verification of this problem, so will keep notes of my steps below.
In Test #1 and Test #2

still broken

  1. Lightsquid - selecting open from Applications gives identical “404 - language not found” error
    (also when selecting Reports / Web proxy stats, but again, settings button leads to appropriate page


  1. Bandwidthd in applications (or Reports / Bandwidth usage) leads to the correct page

  2. Reports / Graphs leads to the graphs page

Testing steps:

  • install Nethserver 7.2 beta 2 from iso as VM in ProxMox environment as before
  • install the following software: SNMP server, Backup, Statistics, Bandwidth monitor, Basic firewall, Simple bandwidth monitor, Web filter, Web proxy
  • set basic configurations (I can provide upon request)
  • test #1 test functionality before applying any software updates
  • install all updates using the software center
  • test #2 after software updates
  • (in previous tests I had restarted all the affected services to no avail… so…)
  • reboot - because why not
  • test #3 Everything works: feeling a bit sheepish for passing over the first rule of IT, guess I’ve gotten a little too used to living in a Linux desktop/server world. Alas, even the best need to reboot from time to time I guess. :wink:

@dev_team, @quality_team does anybody confirm it? :wave:

Sorry, I cannot confirm any case (Bandwidth usage, Graphs, Web proxy stats, on bare-metal server).


As I mentioned above, after a reboot everything worked perfect on both of my installs, so probably a non-issue. Sorry I didn’t think of rebooting at the time. facepalm

Please forgive me, but I don’t think that a reboot could fix all such problems.
As you said, we probably need to restart some services, we need to discover those services and add a restart.
I think that for lightsquid the service could be httpd-admin.

Did you change the hostname before installing languages and/or graphs or lightsquid packages?

It is entirely possible that I changed the hostname and on the first one I did select another language to install. I’m traveling, but next week I’ll be doing another similar install and will try to pay attention to exact steps and report back what I find. Thanks.