Let's encrypt error

letsencrypt
virtualhosts

(Martin Droste) #1

NethServer Version: 7.5.1804
Module: let’s encrypt

Hi all,

everthing worked fine until yesterday morning…I had bee the happiest nethserver-User ever!!!

But now everthing went wrong…

at the moment i get 502 Bad gateaway for my vhost

so I tried to connect only by http, without success so I tried to reactivate ssl for the vhost an thought to ask for a new certificate but i got this:

Domänen
Failed authorization procedure. www.mydomain.de (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: The key authorization file from the server did not match this challenge …

My server is called central.mydomain.lan
The vhost is www.mydomain.de(over selfhost.de to feste-ip.net, for portmapper and https-proxy, to my ipv6 router to my nethserver(ipv6-address)

Yesterday afternoon I installed some updates in nethserver, and after that(not sure, if it could be the reason…) I get the 502 Bad gateaway Error. And before that I tried to install nethserver-Wordpress but deinstalled it becasue of https problems with the .css ans .js files.

any suggestion for me to start my investigation

thx all

martin


(Michael Träumner) #2

Did you try to restart apache?
Is there something at the logs?
I think httpd and messages log are the right one:
Have a look at

/var/log/messages

and all logs at

/var/log/httpd/