Latest Samba update - W10 login error

Hello Nethserver Users/Developers!

Sorry, if this has been already posted, but i couldn’t find it.

So, basically i update our Nethserver every month once, it is installed in hyper-v and runs perfectly fine.
Before every update i make a checkpoint, if something goes wrong i can just roll back with few clicks to the previous version.

So, yesterday i updated the nethserver and after that i restarted it, everything seemd to work fine.
But today in the morning at our workplace we couldn’t login to the clienst which were in domain. (the error message wasn’t in English, but it was something like - A secure connection between client and server couldnt be made. So i restarted the nethserver and the problem still existed. So i rolled back the previous version, after that everything worked again. I think this will be again a registry-trick, NT4 authentication problem. My English isn’t perfect, but i hope u could understand what im trying to tell you all. Did anyone expect me had the same error? Does someone know already a solution for this bug?

Thank you guys in advance, have a nice day!

SJAFKA

Most probably related to:


2 Likes

Yes, it seems to be this bug. Thank you Dnutan!
I see that the current(the restored) samba version in 1.5.4 and the update is 3.6.23(an affected version).
So basically i have to wait now, till its patched, right?

Thank you in advance :slight_smile:

small typo: it is Samba 3.5.4

Yes, you can wait, or update it and try the custom-template from @davidep . If the update throw errors about winexe, read this

Note it’s a security update, thus understand the risks of not having it up to date.

1 Like

Thank you!