KVM config problem with bridge

virtualization
v7

(Roberto) #1

NethServer Version: 7 final
Module: KVM

Hello everyone.
I lost the server …
I tried installing a virtual machine, as I wrote in the manual I created a bridge logic network card, gave it an ip and after restart I see nothing more …
Configuration: Network adapter NetH 7 192.168.1.10 + br0 for active directory (192.168.1.11) Ok.
After add br1 (192.168.1.12), nothing is seen again. Help


(Markus Neuberger) #2

Hello @roberto.schiano,

when I remember correctly you may use the same bridge(green br0) for the VMs that is used for ad, so you don’t need another bridge br1.

Docs:
https://wiki.nethserver.org/doku.php?id=userguide:how_to_configure_and_run_a_vm_with_webvirtmgr_on_nethserver
http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-dc.html#nethserver-dc
http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-base.html?highlight=bridge#bridge


(Roberto) #3

OK perfect. I did not know this WIKI.
But I have already done the new bridge and the server is no longer reachable …
Now, how do I disable br1, I can do only in the console, I dno’t know, I’m not familiar with CentOS.
Thank you


(Markus Neuberger) #4

You may completely reset your network configuration and start over:
http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-base.html#reset-network-configuration

http://docs.nethserver.org/en/v7/webvirtmgr.html


(Michael Träumner) #5

Hi,
I’ve found something

# ip link set br100 down
# brctl delbr br100

at the following site, but not tested.


(Roberto) #6

with these commands. not solved


(Roberto) #7

Made to the letter but nothing. after the “signal-event system-init” command, everything returns as before …


(Roberto) #8

Fixed with VI editor, I edited the “ifcg-ethxx” configuration file, modified the br1 br1 voice edit in br0 and the server came back available.


(Michael Träumner) #9

Ok, could you mark your answer as solution please.