Kernel Panic - after update

NethServer Version: 7.7

I got a kernel panic after update and reboot the machine. I can start the server with an older kernel…

How can I solve it?

I used an older kernel to boot the server. After that, I backed up the latest files via NFS to the backupserver.

Later on, I did a disaster-recovery of the vm (19. Nov) under proxmox. Now I would like to restore the latest files to the running server?

How can I give this Server the latest backup-config-info?

If you have a dedicated boot partition check it has enough free space.
From Internet search the kernel panic could be solved in different ways, but mostly related to a bad initramfs:

One option:

# get the latest initramfs (the one corresponding to the failing kernel boot)
ll /boot/initramfs-*

# Optional: initramfs backup (replace version accordingly)
cp /boot/initramfs-3.10.0-1062.4.3.el7.x86_64.img{,.backup}

# rebuild initramfs
dracut -f /boot/initramfs-3.10.0-1062.4.3.el7.x86_64.img

# reboot

Another option would be to yum reinstall the kernel, or removing the failed kernel and installing it again.

I suggest you to remove kernel and reinstall it with Software Center.

To remove it:

  • start NethServer with an old kernel
  • remove kernel (e.g. yum remove kernel-3.10.0-229.el7.x86_64)
  • download software updates
1 Like

Yes, this worked! Thank you very much…

1 Like

Thank you Marc, I appreciate your help!

Got this msg:

Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
The program yum-complete-transaction is found in the yum-utils package.

Is it safe to use: yum-complete-transaction on NethServer?

It’s used in other threads too so I’d say yes but there are some other solutions that helped: