It is not possible to control the access and security of samba-share from the windows Active Directory snap-in

NethServer Version: nethserver-7.3.1611-x86_64
Module: samba share

The Domain Controller has been created.
Shared resources are created.
Computer with windows 7 is entered into the domain
user - Administrator@domain
If I change the permissions on the shared resource from Windows 7 RSAT “Computer Management” -> NethServer share does not save the changes with the message "Changes can not be saved. Access denied ".
In a simple samba AD solved the command - net rpc rights grant “DOMAIN\Domain Admins” SeDiskOperatorPrivilege -Uadministrator
In does not work - "Failed to grant privileges for DAVIO\Domain admins (NT_STATUS_NO_SUCH_USER)"
Tell me what to do to change “Permissions for the Share” and “Security” From Windows

P.S. The problem is that you need to create a shared resource tree with different access rights to them


For some weird reason, I can not set rights to “Domain Admins@domain.meh” either, the group doesnt exist.
My workaround was using the “Administrator@domain.meh” account, this worked for me.

I do have the proper rights now, but little clue on how the samba settings interact here, but I did notice some rights being reverted to previously entered umask or createmask values, regardles of my edits using mmc.exe’s AD snap-in.

1 Like