It does not complete uninstalling Samba AD when uninstalling it

I tried several times to uninstall Samba Active Directory and it says it did, and not showing the installed in Software Center and is showing in the Add center.

But it’s not completely uninstalled. I shutdown the server and closed the website, and started the server and open the website, but it still not completely uninstalled.

The Domain Accounts:

The User and Group is still showing the Administrator:

Samba Active Directory is showing the Add center though:

After re-install it back again, the website only spins. Nothing else. Win7 can ‘see’ the domain but won’t join.

Have you tried the samba-dc reset I posted in the other thread?

You could try it with samb-dc ‘uninstalled’ but I think it would work properly if it was installed, although at this point I would start over with the install.

1 Like

@fasttech - I haven’t tried it. But uninstalling it should work but it doesn’t, and so posted this as a bug.

Historically, in my minimal experience with linux, etc, 'uninstall…, removal, deals well enough with the actual program, even dependencies, but is crap all when dealing with the many config files that are created throughout. The samba reset does work in the few times I’ve used it for just that, but not when the setup is truly broken.

@fasttech - I tried it and did work.

However, it’s still a bug. And if you want NethServer to be full-fledged Small Business Server that competes with Microsoft (like I want) it’s should be fixed.

NethServer, I think, is trying not be the off-the-wall Linux distro that only Linux professional ( or geeks :wink:) know how to get it work. It should work the way is suppose to do and not the “need to do that or this and that AND this” to get it to work.

Hi fasttech,
I think you mean this Instruction to reset ad.
I think it’s a good idea to implement this to the uninstallation-routine of samba. Is it possible?

1 Like

No it’s not.

Uninstalling the user provider is not a supported scenario, because it’s much complicated to restore the machine in the previous state: you need to follow many steps from command line (and I don’t even know which ones).

To do a good job, we shouldn’t allow to uninstall nethserver-dc and nethserver-directory packages from the web interface.
But I think the effort doesn’t worth it (@davidep am I right?).

In a real server, why a user should really uninstall the user provider? :worried:

3 Likes

If it’s unsupported and breaks the server, maybe we could block it or show a BIG warning :slight_smile:

1 Like

Bingo.

In reality I think this is a tail chaser… anyone seriously setting up an AD server shouldn’t have a use case for later uninstalling the underlying architecture of their whole network other than spinning up a new server install.

The instruction set seems to me to be for an instance of setting up a new environment and oops… I messed up the fqdn or something.

I think we should save ourselves grief by simply not even allowing an uninstall… I know it was a ridiculous proposition in zentyal.

For testing, you should be spinning up fresh installs for whatever you may be testing… or at least using snapshots.

2 Likes

@m.traeumner The ‘reset AD’ works by allowing the installing of AD again with an a virtual IP. But before I do that, I uninstall Samba Active Directory again, and then AD is gone.

I agree with you on this.[quote=“giacomo, post:7, topic:4832”]
In a real server, why a user should really uninstall the user provider? :worried:
[/quote]

Microsoft allows you to do this and since it started AD/DC with Windows 2000. This is for Microsoft Servers 2012 http://blogs.interfacett.com/how-to-demote-a-domain-controller-dc-in-windows-server-2012-active-directory-domain-services-ad-ds

They’re a lot of possibilities why you might take if off. Say you decided you don’t need an AD anymore and so you want to take it off, especially you have very small company. To me it’s good that Microsoft allow you take if off, if you don’t never want to.

Also since NS does not with AD installed by default (Microsoft SBS servers has the AD by default but not the regular standard servers), you should be able to uninstall it.

@alefattorini and @giacomo:

If you can’t fix it, I agree either block it or showing a big warning. But if you do block it or showing a big warning when trying to remove the AD, when someone installs AD if should have another big warning that you can’t take it off before you actually install it.

You’re totally right.
I’m pretty sure this is the best solution, but it takes too much work to get it done.

I’d go with a dedicated chapter inside the administrato manual on how to remove both nethserver-directory and nethserver-nsdc.

Also Samba AD-DC can be “demote” according this (I never tried):

https://wiki.samba.org/index.php/Demote_a_Samba_AD_DC

Anyway, it’s a good lecture:

https://wiki.samba.org/index.php/Main_Page

I just started to read and I think I will find answers to my questions regarding Samba DC-AD-File sharing-RSAT administration.

Do you an additional developer(s)? Or not enough time to get it done for the expected release? It’s the time of the release, will you have time to work on the bug after it’s release? You like you been thinking about it though :slight_smile:

New developers are always welcome! :wink:

This is also true: I would like to release a new rc2 as soon as possible (also probably CentOS 7.3 will be released soon).

We could do it, but honestly this isn’t a priority for two main reasons.

  1. The web interface now works quite well and it’s stable enough. If we want to add such warning, we should add a full new feature which takes care of a “bad list of packages”.
    This list needs to be configurable by the developers because we could add/removed packages during the development cycle.

  2. Also, I give you an insider information (:grin:): we totally removed the uninstall button inside the Enterprise release.

I always stood for having the “Remove package” feature, but during the years this feature raised more problems (and support tickets) then benefits.
This is why I would like to spend time implementing more important features (at least from my point of view), and replace code with documentation whenever possible :smiley:

3 Likes

@giacomo Good point and I agree with you, for now :wink:

1 Like

One reason to remove it is when it doesn’t work. I am getting a yellow warning box that says

Configure Samba Active Directory
The Domain Controller (DC) container must be configured before being started

With a button. I click the button and I get a page that says

Domain rnet.duckdns.org

And a button that says Configure. I click configure, and get the first warning again.

The Domain controller configuration page will not let me edit the settings.

I’ve tried to follow the procedure for the Factory Reset, but I don’t understand the following lines. They don’t appear to be commands

config setprop sssd Provider none status disabled
> /etc/sssd/sssd.conf

/etc/sssd/sssd.conf is empty.

Using 7.3.1611 (rc3)

I think it has to be one line.

config setprop sssd Provider none status disabled > /etc/sssd/sssd.conf

No, those are two separate commands:

  1. disable sssd
  2. clean sssd.conf
1 Like

Um- just for other people who might find this page - not me, you understand - assume I know nothing. Do I need to be in a special directory to run the command or using a special shell or something? I get command not found. A path variable, maybe?

  • The command should be run as an user with administration rights (i.e. root, which has its $PATH variable tweaked for NethServer).
  • The absolute path to the command is /sbin/e-smith/config
  • As the files referenced in those commands are using absolute paths they can be executed from any directory.