Issues with certificates, updating, and httpd not starting

Hi I’m having issues with the httpd not starting. I’m not quite sure whats wrong. Only thing I tried to do today was renew certificates and then after that, nothing worked. I tried updated the whole system. The update looks like it went through.

When I tried to update from the software center, it runs through the update then fails. However, when i go to the terminal and try ‘yum update’ it tells me that theres nothing new to update.

I tried renewing certificates however, it tells me letsencripte/update failed

then I noticed in services ‘httpd’ was not started and then when i try to start it, it tells me that the update fails also.

Any suggestions. I’ve included screenshots for this last issue
. Thank you so much!

NethServer Version: your_version v7
Module: your_module httpd

Hi @whoisu,

If you renew the cert, check if the name of the cert changed to …001.

If so, make sure the defaut cert is the one with the new name.
Do the same if you have vhosts.

Then systemctl restart httpd

If nothing changed, try to assign the original (self-signed) as default


What’s the output of certbot certificates, config show pki, and systemctl status httpd?