Issues copying sogo mail from one nethserver to another

sogo
email

(Thyran John Wright) #1

NethServer Version: NethServer release 7.5.1804 (final)
Module: Sogo

My nethserver installation became inaccessible via ssh and the gui after my servers power supply blew. I have nethserver installed as a vm on proxmox.

I recreated nethserver by installing a new version and then restored settings from a backup.

This replicated all my settings and config to the new server

I managed to get the gui and ssh working by uninstalling cups… dont ask me how that solved the problem i tried ssh to copy mail from the one vm to another and got a cups config error. uninstalled cups and ssh and the gui came back to life. I managed to copy mail from one server to another with the scp command.

But when i log into the account on the new server i can see the new email in the sogo webgui but there is no content on the mail items and when logging in it gives an error no UID.

Can someone help with copying mail in sogo from one nethserver to another so that it is functional


(Rob Bosch) #2

Any chance this is a permissions problem?
Does this help: https://serverfault.com/questions/654789/maildir-new-has-messages-but-inbox-is-empty

Instead of using scp, you could try imapsync
I have successfully moved my mail from an old server to a new one before using this. Here is a howto on imapsync: https://imapsync.lamiral.info/doc/TUTORIAL_Unix.html


(Ralf Jeckel) #3

Proxmox has it’s own shell(console), so you can still access CLI on your “old” server without ssh. You could try to repair your ssh and webgui or network settings on CLI.

db networks show
config show sshd
config show httpd-admin

Another solution could be the hot-sync-module. Old as master, new as slave. After sync, switch new to master. In my case all events and mails were synced during moving from one machine to a new one.
Just an idea. :wink:


(Mark Verlinde) #4

Is the mail available over imap or pop3 with an external mail client?

It is good to understand SOGo complements the (dovecot) mail-server with calendar/tasks and other groupware features. It does not store mail itself.

This being said:

Did you migrate the mysql database of SOGo as well?

The groupware data and features are stored in this data base.

I think a valid point: does it work if you make temporary test-users?


(Mark Verlinde) #5

Sorry "over"read this, why not make a full data-backup on your “old” server and restore it on the new install?


(Thyran John Wright) #6

Hi Mark
I just tried doing a full data backup it was successful in the logs
Backup done via CIFS on a SMB Share
Now I go to the new server GUI and choose restore files but there is no option for me to choose the files from the CIFS share to restore from?
How do you configure the restore-files to read from the CIFS share in order to restore the backup files?


(Mark Verlinde) #7

Sorry, never done this (all infrastructure is linux here :grinning:)

Maybe this helps: