Issue with IPv6 and AD


today I suddenly discovered a NethServer that has always been behind a gateway that supports IPv6 is now unable to communicate with the NSDC on the LAN (that uses no IPv6, only on WAN).

The problem started from the VPN configuration, which was the reason why I logged in, but then I realised also the user tab showed no user and /usr/libexec/nethserver/list-users raised
(No route to host): IO::Socket::INET6: connect: No route to host

I’ve gone ahead and disabled IPv6 system-wide via sysctl net.ipv6.conf.all.disable_ipv6 = 1 but this raises the problem with cockpit mentioned in #19909 . To restore that, I had to systemctl edit --full cockpit.service and set ListenStream=LAN_IP:9090 (the override.conf won’t work).

The server now seems to work normally but this situation is quite weird, hope there’s a easier fix.

Hi @mmaridev/ Marco,
did you neth-ified CentOS7 or did you install from the NethServer Iso?

Hi @pike / Michael,

it was two years ago at this point but since the first command in history is yum install I probably started from a CentOS Cloud Image (it’s a VM in Proxmox).

So the answer seems “Neth-ified CentOS7”.
Long story short: CentOS supports IPv6, Nethserver 7 don’t. Has been asked quite few times, but still not happening; in my personal opinion it won’t happen.

the situation is the one intended by the developers, which supported IPv4 only since 6.5.

Unfortunately I don’t know if there’s, maybe at the beginning of the week a proper and tested setting/command could be reported by the dev team or by the forumers who already encountered this issue.
Documentation has no trace at all about IPv6, wiki reports only info about other modules.
Consider searching discourse for any related topic :wink:

Yeah, that’s what I have done, thus the reference to the other topic.
What worries me the most is that it worked just fine and then, after almost two years, suddenly stopped.
I’m aware that NS does not support IPv6 but it has never been a problem since we have dual stack from the ISP and NS always used IPv4, without giving any trouble with the DC!

Well… the owner of the dead donkey always says “but it was fine until yesterday”. So…
You raised your experience and concern; it’s saturday. Backup and take a break :wink:

1 Like