Issue in update module

yum
updates
v7

(Francesco) #1

NethServer Version: 7.5.1804
Module: update module
Hi guys, I have a problem whit the update module.
I have this error

failure: repodata/repomd.xml from centos-sclo-rh: [Errno 256] No more mirrors to try. http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for centos-sclo-rh: Damaged repomd.xml file

Il comando di aggiornamento/installazione potrebbe essere fallito a causa di problemi nella cache dei metadati. Pulire la cache facendo clic sul pulsante in basso e ripetere l'operazione di installazione/aggiornamento.

Can you help me ?
Thanks in advance
Francesco


(Francesco) #2

whit this command:

yum clean all && rm -rf /var/cache/yum && yum -y update

I have:

Loaded plugins: changelog, fastestmirror, nethserver_events
Cleaning repos: base centos-sclo-rh centos-sclo-sclo epel extras nethforge
              : nethserver-base nethserver-updates updates
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned d                                                                                                                                                             ata from disabled or removed repos
Cleaning up list of fastest mirrors
Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
epel/x86_64/metalink                                     |  32 kB     00:00
 * base: ba.mirror.garr.it
 * epel: pkg.adfinis-sygroup.ch
 * extras: ba.mirror.garr.it
 * nethforge: mirror2.nethserver.org
 * nethserver-base: mirror2.nethserver.org
 * nethserver-updates: mirror2.nethserver.org
 * updates: ba.mirror.garr.it
base                                                     | 3.6 kB     00:00
centos-sclo-rh                                           | 3.8 kB     00:00
http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml: [Errno -1]                                                                                                                                                              Error importing repomd.xml for centos-sclo-rh: Damaged repomd.xml file
Trying other mirror.


 One of the configured repositories failed (CentOS-7 - SCLo rh),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=centos-sclo-rh ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable centos-sclo-rh
        or
            subscription-manager repos --disable=centos-sclo-rh

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=centos-sclo-rh.skip_if_unavailabl                                                                                                                                                             e=true

failure: repodata/repomd.xml from centos-sclo-rh: [Errno 256] No more mirrors to                                                                                                                                                              try.
http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml: [Errno -1]                                                                                                                                                              Error importing repomd.xml for centos-sclo-rh: Damaged repomd.xml file

(Francesco) #3

SOLVED :grin:

I just set “Locked” on “Software updates origin”

Now all works fine
Thanks


(Francesco) #4

Good morning, this morning I again have the same problem in setting the updates on unlocked.
I have this error:
failure: repodata/repomd.xml from centos-sclo-rh: [Errno 256] No more mirrors to try. http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml [Errno 14] HTTP Error 404 - Not Found

The update / installation command may have failed due to problems in the metadata cache. Clean the cache by clicking on the button below and repeat the installation / update operation.

I tried to clear the cache but I did not solve this problem.
I checked the files
CentOS-SCLO-scl.repo

[centos-sclo-sclo]
name=CentOS-7 - SCLo sclo
baseurl=http://mirror.centos.org/centos/7/sclo/$basearch/sclo/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-sclo-testing]
name=CentOS-7 - SCLo sclo Testing
baseurl=http://buildlogs.centos.org/centos/7/sclo/$basearch/sclo/
gpgcheck=0
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-sclo-source]
name=CentOS-7 - SCLo sclo Sources
baseurl=http://vault.centos.org/centos/7/sclo/Source/sclo/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-sclo-debuginfo]
name=CentOS-7 - SCLo sclo Debuginfo
baseurl=http://debuginfo.centos.org/centos/7/sclo/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

CentOS-SCLO-scl-rh.repo

[centos-sclo-rh]
name=CentOS-7 - SCLo rh
baseurl=http://mirror.centos.org/centos/7/sclo/$basearch/rh/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-testing]
name=CentOS-7 - SCLo rh Testing
baseurl=http://buildlogs.centos.org/centos/7/sclo/$basearch/rh/
gpgcheck=0
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-source]
name=CentOS-7 - SCLo rh Sources
baseurl=http://vault.centos.org/centos/7/sclo/Source/rh/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

[centos-sclo-rh-debuginfo]
name=CentOS-7 - SCLo rh Debuginfo
baseurl=http://debuginfo.centos.org/centos/7/sclo/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

and they seem to be ok.
Can you help me?
Thanks in advance


(Francesco) #5

If I clean cache , I have this error:

[root@nethserver ~]# yum clean all
Loaded plugins: changelog, fastestmirror, nethserver_events
Cleaning repos: base centos-sclo-rh centos-sclo-sclo epel extras nethforge
              : nethserver-base nethserver-updates updates
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
[root@nethserver ~]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
epel/x86_64/metalink                                     |  24 kB     00:00
 * base: ba.mirror.garr.it
 * epel: repo.boun.edu.tr
 * extras: ba.mirror.garr.it
 * nethforge: server.liftingtrade.hu
 * nethserver-base: server.liftingtrade.hu
 * nethserver-updates: server.liftingtrade.hu
 * updates: ba.mirror.garr.it
base                                                     | 3.6 kB     00:00
http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.



 One of the configured repositories failed (CentOS-7 - SCLo rh),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=centos-sclo-rh ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable centos-sclo-rh
        or
            subscription-manager repos --disable=centos-sclo-rh

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=centos-sclo-rh.skip_if_unavailable=true

failure: repodata/repomd.xml from centos-sclo-rh: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7/sclo/x86_64/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

(Francesco) #6

Problem solved.
My proxy blocked the mirror.centos.org link.
I apologize