IP unnumbered Client


(Artem Fedai) #1

Hi to all, i have faced with issue while configuring IP unnumbered client. maybe it is about my lack of knowledges.
Please share your thoughts regarding this matter.


(Bogdan Costin) #2

Hi Nas, What do you mean by unnumbered ?


(Artem Fedai) #3

I mean that ip of the server is not in same subnet with default GW


(Rob Bosch) #4

I am afraid you need to be more specific. What different subnets are you talking about? If there is more than 1 sunet, there are only 2 options:

  • use a larger subnetmask
  • use a router and add routes

But i might misunderstood your problem…


(Bogdan Costin) #5

You want to configure a client via DHCP that is not in the default subnet range ?
I’m afraid It is not possible.

The clients have to be in the same range as the DHCP server is (It is the default working model)


#6

Hi,

I dont understand the “unnumberred” client.

Did you mean that the Nethserver must be DHCP relay? To pass through subnet?
Edit: Is the NethServer is a bridge between the GW and the subnet wich need to be DHCP distribued?


(Artem Fedai) #7

Provider gave us “Vlan to Client + proxy_arp” so almoust isolated External net, and from NS if is not possible to reach other provider IP , but i have enable proxy_arp on interface. The initial issue it is that i couldnot reach any providers IP but i need it.


#8

So the provider offer a modem/router with the service or you need to configure Nethserver to do the job?

Plaese, give us informations, details to help in the analisis.

Edit: with the service, the provider communicate if is a fixed ip adress or a dhcp adress? The mask and the Gw.


(Bogdan Costin) #9

I think that the ISP have gave them a static IP with /31 NM assigned to them. They gave them this setup and on the wan they can only see the GW.

I hope I’m not wrong in my assumption but is a common practice between ISP’s


(Artem Fedai) #10

yes you are right /32 and i should add default GW through device eth0 and enable proxy_arp


(Bogdan Costin) #11

Ok that’s good, and the issue is that you have to set this on Eth0 ? or something else ?
The issue with not reaching other ip from the same provider can be outside of the scope. The ISP can have routes set up bad or block access to some IP’s.

What do you need to do exactly ?