IP Blacklist "FireHOL Level 2" vs "FireHOL level 2"

There are two Firehol level 2 lists: “FireHOL Level 2” and “FireHOL level 2”. Which one is the correct one?

The other level are spelled differently, e.g. "Firehol level3

I couldn’t reproduce on a fresh VM, maybe this happens due to ip blacklist updates?

I just have “FireHOL level 2” so I think it’s the right one.

Where does the GUI get the list from?

You define the download url in server manager, see documentation.

Yes, I did this. The question was, where (db or files) the GUI gets the lists from, i.e. where to search for the double entry of “FireHOL Level 2” and “FireHOL level 2” to fix it.

The categories are stored in /usr/share/nethserver-blacklist/ipsets, see documentation.

In your case something like the following command should work:

rm /usr/share/nethserver-blacklist/ipsets/firehol_Level2.netset

Apply config:

signal-event nethserver-blacklist-update

1 Like

There is only one firehol_?evel2.netset not two. If I delete this single one, the whole level 2 is gone, isn’t it? Where comes the spelling for the GUI from? It differs, e.h. “firehol_level2” vs. “FireHOL Level 2” and “FireHOL level 2”.

Output from the ipset directory:

[root@hostname ipsets]# ls -l | grep fire
-rw-r--r-- 1 root root   121574 Oct 11 12:40 firehol_abusers_1d.netset
-rw-r--r-- 1 root root  2844204 Oct 11 12:40 firehol_abusers_30d.netset
-rw-r--r-- 1 root root 26645423 Oct 11 12:40 firehol_anonymous.netset
-rw-r--r-- 1 root root    45644 Oct 11 12:40 firehol_level1.netset
-rw-r--r-- 1 root root   137155 Oct 11 12:40 firehol_level2.netset
-rw-r--r-- 1 root root   253880 Oct 11 12:40 firehol_level3.netset
-rw-r--r-- 1 root root  2544672 Oct 11 12:40 firehol_level4.netset
-rw-r--r-- 1 root root 26563913 Oct 11 12:40 firehol_proxies.netset
-rw-r--r-- 1 root root    13507 Oct 11 12:40 firehol_webclient.netset
-rw-r--r-- 1 root root    32599 Oct 11 12:40 firehol_webserver.netset
-rw-r--r-- 1 root root      829 Apr  1  2021 iblocklist_org_xfire.netset

I can’t get it exactly…I assume it gets the name from the Maintainer in the netset file and the filename.

You may delete or move away the file:

mv /usr/share/nethserver-blacklist/ipsets/firehol_level2.netset ~

and redownload the ipsets:

signal-event nethserver-blacklist-save ipsets

Maybe there’s a problem in your enabled categories? Please share the output of:

config getprop blacklist Categories

1 Like

It seems it gets the name from the ipset filenames:

Althought I do not know if this is used, for some categories there is a language/translation file:

Which language are you using?

In the past the main language file showed level 2 as level 1 but thas was corrected and had not seen any reference to the Level 2 with capital letter.

1 Like

OK, thanks, the language files. I didn’t get where the capital letters at the end in “FireHOL” are coming from.

I use the German setting and found the problem:

There is a wrong translation in the file /usr/share/cockpit/nethserver-blacklist/i18n/language.de.json.gz

“categories”: {
“firehol_level1”: “FireHOL Level 2”,
“firehol_level2”: “FireHOL level 2”,

How to fix this? Is Nethserver translated with transifex like WebTop (where I did many of the German translations)?

1 Like

Yes, see documentation.

How to get member of the Nethserver translation team in transifex (I am already on the Webtop5 tranlation team)?

IIRC you need to join here and you need to be added by an admin…

The URL gives 404 not found. Even when I logged in into transifex. Seems to be a hidden or private project or URL is wrong. My username is chaerle.

After some problems I can access the Nethserver translation page (it really was a rights problem, i.e. not being a member of the translation team).

I just fixed the wrong German translation of “FireHOL level 1”


Do I have to do anything in addition to fixing it in transifex to get the translations propagated into a future nethserver update or is it pullled automatically?

Translations are pulled automatically :wink:

Thank you Carsten for the fix!

1 Like