Ip acquisition in network bridge mode


(nicola) #1

I’m sharing my laptop’s wifi connection with a desktop PC that does not have a wireless network adapter. I’m doing this with an ethernet cable, putting the Ethernet and wireless connection in bridge mode.

In general, usually the network card acquires an initial ip address (without internet connection) that I will subsequently modify, in order to allow the use of the internet connection. this time I do not even find the ip address of the desktop PC, in the DHCP search. then creating a new host and manually entering the mac address, the card does not acquire the new ip. what am I wrong?


(Markus Neuberger) #2

I don’t know if bridging is the best way in this case.
What about Internet Connection Sharing (ICS)? This way the connection will be more automated without need of changing IP address or something like that.

In the end I recommend buying some cheap wifi stick for your desktop PC. This way you don’t need to run your laptop when you need internet on your PC.


(Michael Kicks) #3

You should connect the ethernet cable after the wireless connection and after the creation of the bridge. Therefore, the Desktop ethernet adapter should receive the configuration from DHCP server.

An access point could cost… 30 euro. A wireless USB adapter could cost… 5-10 euro. Think about it.


(nicola) #4

The desktop PC ethernet card already receives the IP from DHCP!

the problem is that the host does not appear in searches and in any case fails to acquire the new IP! maybe I should take off and put the bridge back on?


(Michael Kicks) #5

Why should get a “new ip”?
Maybe DHCP Server leans the address to the wrong address? (Bridge and not ethernet adapter of the desktop PC?


(nicola) #6

the initial ip that acquires the desktop network card is correct. all the hosts that connect the first time, receive an ip of the type “192.168.181.34” because I created a specific ip range and then a profile with filter completely blocked. this to make sure that whoever has the password (the word pass is fast) can not initially have internet connection. so I have to change it.

so everything seems ok, but I do not see the host in the DHCP searches, why?

among other things, the desktop PC has two network cards and then if I connect the cable on the first, it receives an ip, if I connect the cable on the other card, it receives a different ip, so everything seems ok.


(Michael Kicks) #7

I am sorry :frowning: i’m missing the goal for this setup.
Anyway, you could also think for a small subset of ip with proxy authentication… and separated Users/Passwords to allow only to authorized people to access wide across internet


(nicola) #8

thank you. I really like your idea. how do you practically do it?


(Michael Kicks) #9

Define a firewall object for the IP group or range for devices without content filtering. Create more IP groups or range if it’s needed.
Define another firewall object the IP group or range for devices with user managed content filtering

Create users, if not already available.
Enable proxy, authenticated setup.
Add all the ip ranges or group without user insert into “hosts without proxy”, add a entry for each firewall object.
Save config and reload.
Out of the “Hosts without proxy” section username and password should be requested;
passwords should not be stored into computers/browsers.

The object for “guarded” internet access is not “used”, but is useful as checkup for the rest of the objects.

As usual: this is only a proof of concept, i did not tested on real enviroment. Therefore… verify, verify, verify.


(Michael Kicks) #10

any news, @nicovon?


(nicola) #11

honestly, I gave up